#27291 closed defect (duplicate)

about:tor not loading on Windows en-US

Reported by: arthuredelstein Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ff60-esr
Cc: pospeselr Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This is somewhat similar to #26381, but may be a separate issue or even related to #27261.

When I downloaded a fresh Tor Browser, the first time about:tor loaded fine. The second time, it did not load and I see the following error in the browser console:

NS_ERROR_FILE_ACCESS_DENIED: Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIWebNavigation.loadURIWithOptions]
browser-child.js:359

Then if I remove NoScript and HTTPS-E xpis from the extensions directory under profile.default, and restart the browser, about:tor loads properly again. If I add back either of those xpis, and restart the browser *twice*, the second time about:tor fails to load and I see the above error message again.

If I keep NoScript and HTTPS-E in the extensions directory but remove tor-launcher xpi, then I also see about:tor loads correctly.

So there seems to be some weird interaction between tor-launcher and NoScript/HTTPS-E. Perhaps all three tickets (this one, #26381, #27261) have the same underlying cause?

Child Tickets

Change History (3)

comment:1 Changed 11 months ago by gk

Bingo! Setting the sandbox level to 2 solves #27261 for me. Does it solve this bug for you too?

comment:2 Changed 11 months ago by gk

Cc: pospeselr added

If so, I guess we should dupe this over to #26381 which pospeselr is working on.

comment:3 Changed 11 months ago by arthuredelstein

Resolution: duplicate
Status: newclosed

Yes! That "solves" this bug. Duplicate of #26381.

Note: See TracTickets for help on using tickets.