Opened 15 months ago

Closed 15 months ago

Last modified 12 months ago

#27341 closed defect (implemented)

sbws install doc is confusing

Reported by: gabe Owned by: juga
Priority: Medium Milestone: sbws: 1.0.x-final
Component: Core Tor/sbws Version:
Severity: Normal Keywords: sbws-1.0-must-closed-moved-20181128
Cc: pastly, juga, teor Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

https://gitweb.torproject.org/sbws.git/tree/INSTALL.rst#n25

Doesn't state need for python3, and the reference to stem 1.7.0 is confusing. Just stated you want the master branch, and ignore versions for now. Master is 1.6.0dev0 right now, and there is no 1.7.0.

Child Tickets

Change History (7)

comment:1 Changed 15 months ago by gabe

Summary: sbs install doc is confusingsbws install doc is confusing

comment:2 Changed 15 months ago by teor

Here are some more fixes:

Install files should document all the required dependencies, but the sbws install file does not say that sbws needs Tor. Please move the tor install from the deploy file to the install file. Similarly, the Linux, virtualenv, and web server requirements should move from deploy to install.

While you're doing that, please update the web server requirements. Almost all web servers support HEAD and GET. But I think sbws needs a web server that supports range requests?

Please also delete or move the "Run sbws" section from the install file. And please remove the [OBSOLETE DO NOT FOLLOW] section. If you ever need it, you can find it in git.

The end of the install file should tell people to read the deploy file to run sbws.

The deploy file should use the standard example.{com,net,org} domains:
https://en.wikipedia.org/wiki/Example.com

comment:3 Changed 15 months ago by juga

Owner: set to juga
Status: newassigned

Assign myself.
I think this ticket should be in milestone sbws 1.0 (must)

comment:4 Changed 15 months ago by teor

Milestone: sbws 1.0 (MVP must)

comment:5 Changed 15 months ago by juga

Status: assignedneeds_review

comment:6 Changed 15 months ago by pastly

Resolution: implemented
Status: needs_reviewclosed

comment:7 Changed 12 months ago by teor

Keywords: sbws-1.0-must-closed-moved-20181128 added
Milestone: sbws 1.0 (MVP must)sbws: 1.0.x-final

Move all closed sbws 1.0 must tickets to sbws 1.0.x-final

Note: See TracTickets for help on using tickets.