Opened 8 years ago

Closed 8 years ago

#2737 closed defect (not a bug)

Detect external IP adress when behind a firewall

Reported by: chiiph Owned by: chiiph
Priority: Medium Milestone:
Component: Archived/Vidalia Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Migrated from old trac:
"I'm using tor behind a firewall. When i'm using the option "mirror the relay directory" i get a message in the logfile that tor can't determine my external adress. To use this i have to manualy add my external adress to the torrc file. Can you make this option available in the vidalia control panel. Somewhere near the directory portnumber an input field to provide the external ip-adress.

A nicer why whould be to have vidalia detect the external ip-adress."

Child Tickets

Change History (2)

comment:1 Changed 8 years ago by arma

In theory, Vidalia isn't supposed to care about Tor's IP address. Tor is supposed to guess it correctly.

And now that there's the 'custom torrc lines' section in Advanced, if Tor gets it wrong you can notice in the log window and fix it.

Without a more precise bug report (why it wasn't learning the IP address), I'm not sure there's anything to fix here.

comment:2 Changed 8 years ago by chiiph

Resolution: not a bug
Status: newclosed

Fair enough.

Note: See TracTickets for help on using tickets.