Opened 15 months ago

Closed 14 months ago

Last modified 12 months ago

#27440 closed defect (not a bug)

GCC Build of Android NDK

Reported by: sisbell Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-rbm, tbb-mobile, TorBrowserTeam201810R
Cc: sisbell Actual Points:
Parent ID: #26693 Points:
Reviewer: Sponsor: Sponsor8

Description

Add library dependencies (in RBM config) needed for gcc to build the Android NDK.

Child Tickets

Change History (8)

comment:2 Changed 15 months ago by boklm

Keywords: TorBrowserTeam201809R added; TorBrowserTeam201808 removed
Status: newneeds_review

comment:3 Changed 15 months ago by gk

Keywords: TorBrowserTeam201810R added; TorBrowserTeam201809R removed

Moving review tickets to October

comment:4 Changed 14 months ago by sisbell

Recent changes to android-toolchain project have broken this part of the build. Working on that now.

comment:5 Changed 14 months ago by sisbell

It looks like we can configure the mozconfig file to use the android NDK's version of clang/llvm. I'm going to revert the changes to gcc and llvm projects and then we can close out this issue.

comment:6 Changed 14 months ago by sisbell

I deleted the commit for changes to the gcc and llvm projects. We can close this issue, as no changes are needed.

comment:7 Changed 14 months ago by gk

Resolution: not a bug
Status: needs_reviewclosed

Closing then (sisbell: feel free to do it yourself if you think a ticket is not needed anymore).

comment:8 Changed 12 months ago by gk

Sponsor: Sponsor8

More Sponsor8 items.

Note: See TracTickets for help on using tickets.