Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#2745 closed defect (duplicate)

Bug: ORPort found reachable, but I have no routerinfo yet. Failing to inform controller of success.

Reported by: carlos Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.2.23-alpha
Severity: Keywords: routerinfo tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Bug: ORPort found reachable, but I have no routerinfo yet. Failing to inform controller of success.

despite this, aterwards success was taken,

see full log
#==========================================================#
Mar 12 23:41:29.540 [Notice] Tor v0.2.2.23-alpha (git-b85eb949b528f4d7). This is experimental software. Do not rely on it for strong anonymity. (Running on Windows XP Service Pack 3 [workstation])
Mar 12 23:41:29.540 [Notice] Initialized libevent version 1.4.14-stable using method win32. Good.
Mar 12 23:41:29.540 [Notice] Opening OR listener on 0.0.0.0:9001
Mar 12 23:41:29.540 [Notice] Opening Directory listener on 0.0.0.0:9030
Mar 12 23:41:29.540 [Notice] Opening Socks listener on 127.0.0.1:9050
Mar 12 23:41:29.540 [Notice] Opening Socks listener on 192.168.0.1:9050
Mar 12 23:41:29.540 [Notice] Opening Control listener on 127.0.0.1:9051
Mar 12 23:41:29.540 [Notice] Based on 683 circuit times, it looks like we don't need to wait so long for circuits to finish. We will now assume a circuit is too slow to use after waiting 46 seconds.
Mar 12 23:41:38.759 [Notice] Parsing GEOIP file C:\Documents and Settings\Administrator\Application Data\tor\geoip.
Mar 12 23:41:38.759 [Notice] OpenSSL OpenSSL 0.9.8p 16 Nov 2010 looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation
Mar 12 23:41:38.759 [Notice] Your Tor server's identity key fingerprint is 'lupus 0FFDC58571B13F1B325928A8CEE57E5266258685'
Mar 12 23:41:38.759 [Notice] We now have enough directory information to build circuits.
Mar 12 23:41:38.759 [Notice] Bootstrapped 80%: Connecting to the Tor network.
Mar 12 23:41:38.759 [Notice] New control connection opened.
Mar 12 23:41:39.368 [Notice] Bootstrapped 85%: Finishing handshake with first hop.
Mar 12 23:41:42.368 [Notice] Bootstrapped 90%: Establishing a Tor circuit.
Mar 12 23:41:47.275 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Mar 12 23:41:47.275 [Notice] Bootstrapped 100%: Done.
Mar 12 23:42:15.868 [Notice] Self-testing indicates your ORPort is reachable from the outside. Excellent. Publishing server descriptor.
Mar 12 23:42:15.978 [Warning] router_orport_found_reachable(): Bug: ORPort found reachable, but I have no routerinfo yet. Failing to inform controller of success.
Mar 12 23:42:47.337 [Notice] Guessed our IP address as 187.24.109.0 (source: 86.59.21.38).
Mar 12 23:42:54.697 [Notice] Self-testing indicates your DirPort is reachable from the outside. Excellent.
Mar 12 23:42:57.275 [Notice] Self-testing indicates your ORPort is reachable from the outside. Excellent. Publishing server descriptor.
Mar 12 23:44:02.306 [Notice] Performing bandwidth self-test...done.
Mar 12 23:44:13.509 [Notice] Your DNS provider gave an answer for "v3w3fsf5pug2xusy.com", which is not supposed to exist. Apparently they are hijacking DNS failures. Trying to correct for this. We've noticed 1 possibly bad address so far.
Mar 12 23:44:13.618 [Notice] Your DNS provider has given "92.242.144.2" as an answer for 11 different invalid addresses. Apparently they are hijacking DNS failures. I'll try to correct for this by treating future occurrences of "92.242.144.2" as 'not found'.

thanks

Child Tickets

Change History (3)

comment:1 Changed 8 years ago by arma

Milestone: Tor Status Deployment
Resolution: duplicate
Status: newclosed

Duplicate of #1172.

Thanks for the logs though -- I just posted a potential fix to #1172.

comment:2 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:3 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.