Opened 5 months ago

Closed 5 months ago

#27481 closed defect (duplicate)

Bug: src/core/mainloop/connection.c:5109: assert_connection_ok: Assertion or_conn->tls failed

Reported by: dgoulet Owned by:
Priority: Medium Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: regression
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Latest git master 06c14f920900f99935e0cf6072aeb50231464eba asserts reliably everytime it tries to boostrap. Triggered on one of my relay (no weird or special configuration). See info.log attached:

Sep 05 20:02:59.636 [err] tor_assertion_failed_(): Bug: src/core/mainloop/connection.c:5109: assert_connection_ok: Assertion or_conn->tls failed; aborting. (on Tor 0.3.5.0-alpha-dev 06c14f920900f999)
Sep 05 20:02:59.636 [err] Bug: Assertion or_conn->tls failed in assert_connection_ok at src/core/mainloop/connection.c:5109. Stack trace: (on Tor 0.3.5.0-alpha-dev 06c14f920900f999)
Sep 05 20:02:59.636 [err] Bug:     ./git/tor/src/app/tor(log_backtrace_impl+0x47) [0x5650452200b7] (on Tor 0.3.5.0-alpha-dev 06c14f920900f999)
Sep 05 20:02:59.636 [err] Bug:     ./git/tor/src/app/tor(tor_assertion_failed_+0x94) [0x56504521b824] (on Tor 0.3.5.0-alpha-dev 06c14f920900f999)
Sep 05 20:02:59.636 [err] Bug:     ./git/tor/src/app/tor(assert_connection_ok+0x575) [0x5650451aaed5] (on Tor 0.3.5.0-alpha-dev 06c14f920900f999)
Sep 05 20:02:59.636 [err] Bug:     ./git/tor/src/app/tor(connection_mark_for_close_internal_+0x27) [0x5650451ab4e7] (on Tor 0.3.5.0-alpha-dev 06c14f920900f999)
Sep 05 20:02:59.636 [err] Bug:     ./git/tor/src/app/tor(connection_handle_read+0x517) [0x5650451afa07] (on Tor 0.3.5.0-alpha-dev 06c14f920900f999)
Sep 05 20:02:59.636 [err] Bug:     ./git/tor/src/app/tor(+0x5745e) [0x56504508b45e] (on Tor 0.3.5.0-alpha-dev 06c14f920900f999)
Sep 05 20:02:59.637 [err] Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x819) [0x7fc50440e4c9] (on Tor 0.3.5.0-alpha-dev 06c14f920900f999)
Sep 05 20:02:59.637 [err] Bug:     ./git/tor/src/app/tor(do_main_loop+0x1fa) [0x56504508d6fa] (on Tor 0.3.5.0-alpha-dev 06c14f920900f999)
Sep 05 20:02:59.637 [err] Bug:     ./git/tor/src/app/tor(tor_run_main+0x11d5) [0x56504508fdc5] (on Tor 0.3.5.0-alpha-dev 06c14f920900f999)
Sep 05 20:02:59.637 [err] Bug:     ./git/tor/src/app/tor(tor_main+0x3a) [0x56504508804a] (on Tor 0.3.5.0-alpha-dev 06c14f920900f999)
Sep 05 20:02:59.637 [err] Bug:     ./git/tor/src/app/tor(main+0x19) [0x565045087bc9] (on Tor 0.3.5.0-alpha-dev 06c14f920900f999)
Sep 05 20:02:59.637 [err] Bug:     /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0) [0x7fc503326830] (on Tor 0.3.5.0-alpha-dev 06c14f920900f999)
Sep 05 20:02:59.637 [err] Bug:     ./git/tor/src/app/tor(_start+0x29) [0x565045087c19] (on Tor 0.3.5.0-alpha-dev 06c14f920900f999)

Child Tickets

Attachments (1)

info.log (314.1 KB) - added by dgoulet 5 months ago.

Download all attachments as: .zip

Change History (2)

Changed 5 months ago by dgoulet

Attachment: info.log added

comment:1 Changed 5 months ago by nickm

Resolution: duplicate
Status: newclosed

Closing as duplicate of #27500, since that one has a nicer number and I saw it first. :)

Note: See TracTickets for help on using tickets.