Opened 3 months ago

Closed 3 months ago

Last modified 5 weeks ago

#27482 closed defect (fixed)

tor browser 8 - crash on startup on osx 10.9

Reported by: user_1234 Owned by: tbb-team
Priority: Very High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-8.0-issues, tbb-regression, TorBrowserTeam201809, tbb-8.0.1-can
Cc: winter2018, fillbert46, nicola, xtor1, giloveve, gra, ksk18 Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by arma)

installed version Version 8.0 of tor browser
as stated here: https://www.torproject.org/download/download-easy.html#mac
OS X (10.9+) should still be supported

###
Dyld Error Message:
  Symbol not found: _mach_approximate_time
  Referenced from: /Applications/Tor Browser.app/Contents/MacOS/Tor/tor.real
  Expected in: /usr/lib/libSystem.B.dylib
###

full crash log

Process:         tor.real [73130]
Path:            /Applications/Tor Browser.app/Contents/MacOS/Tor/tor.real
Identifier:      tor.real
Version:         ???
Code Type:       X86-64 (Native)
Parent Process:  firefox [73122]
Responsible:     firefox [73122]
User ID:         501

Date/Time:       2018-09-05 22:53:02.916 +0200
OS Version:      Mac OS X 10.9.5 (13F1911)
Report Version:  11
Anonymous UUID:  1A1B7ABF-7685-A480-3603-568CD1DBB7A3

Sleep/Wake UUID: B15AAD71-9275-4DF5-AD8A-783DCD8A62E6

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Dyld Error Message:
  Symbol not found: _mach_approximate_time
  Referenced from: /Applications/Tor Browser.app/Contents/MacOS/Tor/tor.real
  Expected in: /usr/lib/libSystem.B.dylib
Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   dyld                          	0x00007fff6dc8a09d dyld_fatal_error + 1
1   dyld                          	0x00007fff6dc8cdf6 dyld::fastBindLazySymbol(ImageLoader**, unsigned long) + 171
2   libdyld.dylib                 	0x00007fff8d6ce2dd dyld_stub_binder_ + 13
3   ???                           	0x0000000103ec9030 0 + 4360802352
4   tor.real                      	0x0000000103b9a95e tor_run_main + 94
5   tor.real                      	0x0000000103c088b6 tor_main + 70
6   tor.real                      	0x0000000103adc65b main + 27
7   tor.real                      	0x0000000103adc634 start + 52
Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x00007fff6dcbedb0  rbx: 0x00007f95fad00300  rcx: 0x0000000000000000  rdx: 0x0000000000000000
  rdi: 0x00007fff6dcbef20  rsi: 0x0000000000000000  rbp: 0x00007fff5c124540  rsp: 0x00007fff5c124528
   r8: 0x00007fff6dca9b8c   r9: 0x0000000000000000  r10: 0x00007fff5c1242a7  r11: 0x00007fff6dcbef20
  r12: 0x0000000000000000  r13: 0x0000000000000000  r14: 0x00007fff6dcbef20  r15: 0x0000000000000000
  rip: 0x00007fff6dc8a09d  rfl: 0x0000000000000246  cr2: 0x00007faeeb40b350
  
Logical CPU:     1
Error Code:      0x00000000
Trap Number:     3
Binary Images:
       0x103adb000 -        0x103ec8cc7 +tor.real (???) <C2959D63-1711-3983-A908-C63276915B95> /Applications/Tor Browser.app/Contents/MacOS/Tor/tor.real
       0x103ff3000 -        0x104031ff7 +libevent-2.1.6.dylib (7.2) <CD222822-C9B1-3CB0-A736-CF75F2B8D98E> /Applications/Tor Browser.app/Contents/MacOS/Tor/libevent-2.1.6.dylib
    0x7fff6dc89000 -     0x7fff6dcbc887  dyld (239.5) <1D3130FE-FE7E-3C4C-8E74-EB51895B6BA5> /usr/lib/dyld
    0x7fff8a0c6000 -     0x7fff8a14ffef  libsystem_c.dylib (997.90.5) <889AA3F9-121C-3985-8B1D-5E908C5693BC> /usr/lib/system/libsystem_c.dylib
    0x7fff8a150000 -     0x7fff8a154ff7  libcache.dylib (62) <BDC1E65B-72A1-3DA3-A57C-B23159CAAD0B> /usr/lib/system/libcache.dylib
    0x7fff8a155000 -     0x7fff8a15dfff  libsystem_dnssd.dylib (522.92.3) <1418DF66-01BE-3A87-8553-09EAA945F4FE> /usr/lib/system/libsystem_dnssd.dylib
    0x7fff8a4ea000 -     0x7fff8a4f1ffb  libcopyfile.dylib (103.92.1) <CF29DFF6-0589-3590-834C-82E2316612E8> /usr/lib/system/libcopyfile.dylib
    0x7fff8a7d6000 -     0x7fff8a7f0fff  libdispatch.dylib (339.92.1) <C4E4A18D-3C3B-3C9C-8709-A4270D998DE7> /usr/lib/system/libdispatch.dylib
    0x7fff8aafc000 -     0x7fff8ab00ff7  libsystem_stats.dylib (93.90.3) <2304C7C2-BE45-35DE-BCC6-707D61B7AE7E> /usr/lib/system/libsystem_stats.dylib
    0x7fff8ab01000 -     0x7fff8ab12ff7  libsystem_asl.dylib (217.1.4) <655FB343-52CF-3E2F-B14D-BEBF5AAEF94D> /usr/lib/system/libsystem_asl.dylib
    0x7fff8bdcb000 -     0x7fff8bdfafd2  libsystem_m.dylib (3047.16) <B7F0E2E4-2777-33FC-A787-D6430B630D54> /usr/lib/system/libsystem_m.dylib
    0x7fff8cd42000 -     0x7fff8cd43fff  libsystem_sandbox.dylib (278.11.2) <0C93EB23-7364-3670-B511-212A7A524695> /usr/lib/system/libsystem_sandbox.dylib
    0x7fff8d654000 -     0x7fff8d655fff  libunc.dylib (28) <62682455-1862-36FE-8A04-7A6B91256438> /usr/lib/system/libunc.dylib
    0x7fff8d6cd000 -     0x7fff8d6d0ff7  libdyld.dylib (239.5) <CAE7A50D-F156-3D47-81C0-DC41EB975D38> /usr/lib/system/libdyld.dylib
    0x7fff8e18a000 -     0x7fff8e18bffb  libremovefile.dylib (33) <3543F917-928E-3DB2-A2F4-7AB73B4970EF> /usr/lib/system/libremovefile.dylib
    0x7fff8e20b000 -     0x7fff8e20bff7  libkeymgr.dylib (28) <3AA8D85D-CF00-3BD3-A5A0-E28E1A32A6D8> /usr/lib/system/libkeymgr.dylib
    0x7fff8fc89000 -     0x7fff8fcadfff  libxpc.dylib (300.90.2) <AB40CD57-F454-3FD4-B415-63B3C0D5C624> /usr/lib/system/libxpc.dylib
    0x7fff9028c000 -     0x7fff902dafff  libcorecrypto.dylib (161.1) <F3973C28-14B6-3006-BB2B-00DD7F09ABC7> /usr/lib/system/libcorecrypto.dylib
    0x7fff903d2000 -     0x7fff903d4ff3  libsystem_configuration.dylib (596.15) <4998CB6A-9D54-390A-9F57-5D1AC53C135C> /usr/lib/system/libsystem_configuration.dylib
    0x7fff908e2000 -     0x7fff90a8ff27  libobjc.A.dylib (551.1) <AD7FD984-271E-30F4-A361-6B20319EC73B> /usr/lib/libobjc.A.dylib
    0x7fff9148a000 -     0x7fff914a5ff7  libsystem_malloc.dylib (23.10.1) <A695B4E4-38E9-332E-A772-29D31E3F1385> /usr/lib/system/libsystem_malloc.dylib
    0x7fff9160b000 -     0x7fff9160dff7  libquarantine.dylib (71) <7A1A2BCB-C03D-3A25-BFA4-3E569B2D2C38> /usr/lib/system/libquarantine.dylib
    0x7fff91e76000 -     0x7fff91e7dff7  libsystem_pthread.dylib (53.1.4) <AB498556-B555-310E-9041-F67EC9E00E2C> /usr/lib/system/libsystem_pthread.dylib
    0x7fff924fc000 -     0x7fff92523ffb  libsystem_info.dylib (449.1.4) <12CD9E42-8CEE-3A8D-B006-F8A6EB98804D> /usr/lib/system/libsystem_info.dylib
    0x7fff925e0000 -     0x7fff925e1ff7  libSystem.B.dylib (1197.1.1) <72A98ACC-7606-3AD5-82AF-02D4EBBD4F02> /usr/lib/libSystem.B.dylib
    0x7fff92818000 -     0x7fff9281ffff  libcompiler_rt.dylib (35) <4CD916B2-1B17-362A-B403-EF24A1DAC141> /usr/lib/system/libcompiler_rt.dylib
    0x7fff92d44000 -     0x7fff92d96fff  libc++.1.dylib (120) <4F68DFC5-2077-39A8-A449-CAC5FDEE7BDE> /usr/lib/libc++.1.dylib
    0x7fff9330a000 -     0x7fff9330bff7  libsystem_blocks.dylib (63) <FB856CD1-2AEA-3907-8E9B-1E54B6827F82> /usr/lib/system/libsystem_blocks.dylib
    0x7fff934f2000 -     0x7fff934f9ff8  liblaunch.dylib (842.92.1) <A40A0C7B-3216-39B4-8AE0-B5D3BAF1DA8A> /usr/lib/system/liblaunch.dylib
    0x7fff937ef000 -     0x7fff937f8ffb  libsystem_notify.dylib (121.20.1) <9B34B4FE-F5AD-3F09-A5F0-46AFF3571323> /usr/lib/system/libsystem_notify.dylib
    0x7fff95508000 -     0x7fff9550dff7  libunwind.dylib (35.3) <78DCC358-2FC1-302E-B395-0155B47CB547> /usr/lib/system/libunwind.dylib
    0x7fff95514000 -     0x7fff95515ff7  libDiagnosticMessagesClient.dylib (100) <4CDB0F7B-C0AF-3424-BC39-495696F0DB1E> /usr/lib/libDiagnosticMessagesClient.dylib
    0x7fff956f9000 -     0x7fff9573bff7  libauto.dylib (185.5) <F45C36E8-B606-3886-B5B1-B6745E757CA8> /usr/lib/libauto.dylib
    0x7fff95fcf000 -     0x7fff95fe0ff7  libz.1.dylib (53) <42E0C8C6-CA38-3CA4-8619-D24ED5DD492E> /usr/lib/libz.1.dylib
    0x7fff96265000 -     0x7fff9626afff  libmacho.dylib (845) <1D2910DF-C036-3A82-A3FD-44FF73B5FF9B> /usr/lib/system/libmacho.dylib
    0x7fff962b8000 -     0x7fff962e1ff7  libc++abi.dylib (49.1) <21A807D3-6732-3455-B77F-743E9F916DF0> /usr/lib/libc++abi.dylib
    0x7fff9682f000 -     0x7fff9684bff7  libsystem_kernel.dylib (2422.115.15) <34ABAF79-E147-3C34-B05D-46A566E689CC> /usr/lib/system/libsystem_kernel.dylib
    0x7fff96eb4000 -     0x7fff96ebefff  libcommonCrypto.dylib (60049) <8C4F0CA0-389C-3EDC-B155-E62DD2187E1D> /usr/lib/system/libcommonCrypto.dylib
    0x7fff97533000 -     0x7fff97539ff7  libsystem_platform.dylib (24.90.1) <3C3D3DA8-32B9-3243-98EC-D89B9A1670B3> /usr/lib/system/libsystem_platform.dylib
    0x7fff9753a000 -     0x7fff97561ff7  libsystem_network.dylib (241.4) <0D630D53-C772-3EC5-8257-EFB0ACCE3153> /usr/lib/system/libsystem_network.dylib
External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 202397
    thread_create: 0
    thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=76.5M resident=14.8M(19%) swapped_out_or_unallocated=61.7M(81%)
Writable regions: Total=18.5M written=84K(0%) resident=152K(1%) swapped_out=0K(0%) unallocated=18.3M(99%)
 
REGION TYPE                      VIRTUAL
===========                      =======
Kernel Alloc Once                     4K
MALLOC                             10.2M
MALLOC (admin)                       16K
STACK GUARD                        56.0M
Stack                              8192K
VM_ALLOCATE                           8K
__DATA                              884K
__LINKEDIT                         67.2M
__TEXT                             9436K
shared memory                         4K
===========                      =======
TOTAL                             151.5M

Model: MacBookPro7,1, BootROM MBP71.0039.B0E, 2 processors, Intel Core 2 Duo, 2.4 GHz, 8 GB, SMC 1.62f7
Graphics: NVIDIA GeForce 320M, NVIDIA GeForce 320M, PCI, 256 MB
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1067 MHz, 0x80AD, 0x484D54333531533642465238432D47372020
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1067 MHz, 0x80AD, 0x484D54333531533642465238432D47372020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (5.106.98.100.22)
Bluetooth: Version 5.2.7f4 15858, 3 services, 15 devices, 1 incoming serial ports
Network Service: USB Ethernet 2, Ethernet, en5
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: Hitachi HTS545025B9SA02, 250,06 GB
Serial ATA Device: MATSHITADVD-R   UJ-898
USB Device: Built-in iSight
USB Device: AX88772C
USB Device: Internal Memory Card Reader
USB Device: BRCM2046 Hub
USB Device: Bluetooth USB Host Controller
USB Device: IR Receiver
USB Device: Apple Internal Keyboard / Trackpad
Thunderbolt Bus: 

Child Tickets

Attachments (4)

tor_crash_osx_10_9.txt (9.7 KB) - added by user_1234 3 months ago.
crash log
screenshot 2018-09-06 at 01.48.53.jpg (10.9 KB) - added by user_1234 3 months ago.
screenshot 2018-09-06 at 01.48.00.jpg (43.9 KB) - added by user_1234 3 months ago.
screenshot 2018-09-06 at 01.47.50.jpg (30.3 KB) - added by user_1234 3 months ago.

Download all attachments as: .zip

Change History (26)

Changed 3 months ago by user_1234

Attachment: tor_crash_osx_10_9.txt added

crash log

comment:1 Changed 3 months ago by arma

Component: - Select a componentApplications/Tor Browser
Description: modified (diff)
Owner: set to tbb-team

comment:2 Changed 3 months ago by arma

Hey, this looks like #26876.

Looks like it is a Tor bug, and it is fixed in release-0.3.3 branch, but no release has been made yet that includes the fix.

comment:3 Changed 3 months ago by user_1234

ok great!
thanks!

comment:4 Changed 3 months ago by pospeselr

Looks like this will have to wait until #26876 hits tor stable OR we could perhaps grab and apply the patch ( https://github.com/teor2345/tor/commit/022b8f15da2b349aaffc5aab311bdd3e0a7fa199 ) and define MAC_OS_X_VERSION_MIN_REQUIRED=1009 in the tor rbm project build file (we would need to apply this define regardless it looks like).

EDIT: Seems this went in to 0.3.4.6-rc (and tbb builds 0.3.4.7-rc) so we just need to update our build configuration to add that define

Last edited 3 months ago by pospeselr (previous) (diff)

comment:5 in reply to:  2 ; Changed 3 months ago by arma

Replying to arma:

it is fixed in release-0.3.3 branch, but no release has been made yet that includes the fix.

Ok, I now believe the fix is in 0.3.4.6-rc and 0.3.4.7-rc, but that we fucked up the changelog for those releases so the changes entry is missing from them.

So if Tor Browser 8 ships with Tor 0.3.4.7-rc, then something needs to happen in the Tor Browser build process to enable the #26876 fix.

comment:6 in reply to:  5 Changed 3 months ago by arma

Replying to arma:

So if Tor Browser 8 ships with Tor 0.3.4.7-rc

Ok, boklm's tor-announce just now says it ships with Tor 0.3.3.9. So if you want this bug tackled in Tor Browser 8, you'll need to either get us to make an 0.3.3.10, or apply the patch yourself. And then maybe change the build process as above, I'm not sure. :)

comment:7 Changed 3 months ago by arma

user_1234: can you try the Tor Browser 8.5a1 release on your OSX 10.9?

It should include Tor 0.3.4.7-rc, which should include the fix for #26876. So if it works, yay we know what to do, if it doesn't work, there's more to be done.

comment:8 Changed 3 months ago by user_1234

yes
reporting then back here

comment:9 Changed 3 months ago by user_1234

i can confirm that "Tor Browser 8.5a1" works on my "OSX 10.9.5"!

Last edited 3 months ago by user_1234 (previous) (diff)

Changed 3 months ago by user_1234

Changed 3 months ago by user_1234

Changed 3 months ago by user_1234

comment:10 Changed 3 months ago by user_1234

the dmg layout is kinda messed up and the bundle name changed but the application works normaly
maybe you can forward the screenshots to an issue
thanks!

Last edited 3 months ago by user_1234 (previous) (diff)

comment:11 Changed 3 months ago by gk

Keywords: tbb-8.0-issues tbb-regression TorBrowserTeam201809 added

I think the messed up dmg layout is #26263. We wanted to wait for the new browser icons before working on that...

comment:12 Changed 3 months ago by arma

Summary for people having this issue: either switch to Tor Browser 8.5a1 now -- which has this issue fixed -- or wait a few weeks until Tor Browser 8.0.1, which should include the fix too.

comment:13 Changed 3 months ago by gk

Cc: winter2018 added

#27581 is a duplicate.

comment:14 Changed 3 months ago by mcs

Cc: fillbert46 added

#27617 is a duplicate.

comment:15 Changed 3 months ago by gk

Keywords: tbb-8.0.1-can added

Marking for 8.0.1 can.

comment:16 Changed 3 months ago by gk

Resolution: fixed
Status: newclosed

I picked 0.3.4.8 as the Tor we'll ship in 8.0.1 (commit 6d09f7a6b7cffc04551f8909fde975f9e21f2d96 on maint-8.0).

comment:17 Changed 3 months ago by catalyst

#27693 seems to be a duplicate.

comment:18 Changed 3 months ago by mcs

Cc: nicola added

comment:19 Changed 3 months ago by gk

Cc: xtor1 added

#27777 is a duplicate.

comment:20 Changed 3 months ago by gk

Cc: giloveve added

Closed #27776 as a duplicate.

comment:21 Changed 3 months ago by gk

Cc: gra added

#27780 is a duplicate.

comment:22 Changed 5 weeks ago by gk

Cc: ksk18 added

Resolved #28289 as a duplicate.

Note: See TracTickets for help on using tickets.