Opened 6 weeks ago

Closed 6 weeks ago

#27500 closed defect (fixed)

Tor crashes upon ORPort disconnection

Reported by: atagar Owned by: nickm
Priority: High Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version:
Severity: Blocker Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi Nick, as discussed this morning tor had a regression between commits fd994f5-b8a2bdb. Tor crashes when Stem attempts to connect with its ORPort then disconnect. Here's its stacktrace...

Sep 05 20:36:47.000 [err] tor_assertion_failed_(): Bug: src/core/mainloop/connection.c:5109: assert_connection_ok: Assertion or_conn->tls failed; aborting. (on Tor 0.3.5.0-alpha-dev b8a2bdbdc8c46776)
Sep 05 20:36:47.000 [err] Bug: Assertion or_conn->tls failed in assert_connection_ok at src/core/mainloop/connection.c:5109. Stack trace: (on Tor 0.3.5.0-alpha-dev b8a2bdbdc8c46776)
Sep 05 20:36:47.000 [err] Bug:     tor(log_backtrace_impl+0x47) [0x55fcc4c95447] (on Tor 0.3.5.0-alpha-dev b8a2bdbdc8c46776)
Sep 05 20:36:47.000 [err] Bug:     tor(tor_assertion_failed_+0x94) [0x55fcc4c90bb4] (on Tor 0.3.5.0-alpha-dev b8a2bdbdc8c46776)
Sep 05 20:36:47.000 [err] Bug:     tor(assert_connection_ok+0x575) [0x55fcc4c240a5] (on Tor 0.3.5.0-alpha-dev b8a2bdbdc8c46776)
Sep 05 20:36:47.000 [err] Bug:     tor(connection_mark_for_close_internal_+0x27) [0x55fcc4c246b7] (on Tor 0.3.5.0-alpha-dev b8a2bdbdc8c46776)
Sep 05 20:36:47.000 [err] Bug:     tor(connection_handle_read+0x517) [0x55fcc4c28bb7] (on Tor 0.3.5.0-alpha-dev b8a2bdbdc8c46776)
Sep 05 20:36:47.000 [err] Bug:     tor(+0x5470e) [0x55fcc4b0470e] (on Tor 0.3.5.0-alpha-dev b8a2bdbdc8c46776)
Sep 05 20:36:47.000 [err] Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x819) [0x7fb789e174c9] (on Tor 0.3.5.0-alpha-dev b8a2bdbdc8c46776)
Sep 05 20:36:47.000 [err] Bug:     tor(do_main_loop+0x1fa) [0x55fcc4b069aa] (on Tor 0.3.5.0-alpha-dev b8a2bdbdc8c46776)
Sep 05 20:36:47.000 [err] Bug:     tor(tor_run_main+0x11d5) [0x55fcc4b09065] (on Tor 0.3.5.0-alpha-dev b8a2bdbdc8c46776)
Sep 05 20:36:47.000 [err] Bug:     tor(tor_main+0x3a) [0x55fcc4b012fa] (on Tor 0.3.5.0-alpha-dev b8a2bdbdc8c46776)
Sep 05 20:36:47.000 [err] Bug:     tor(main+0x19) [0x55fcc4b00e79] (on Tor 0.3.5.0-alpha-dev b8a2bdbdc8c46776)
Sep 05 20:36:47.000 [err] Bug:     /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0) [0x7fb789196830] (on Tor 0.3.5.0-alpha-dev b8a2bdbdc8c46776)
Sep 05 20:36:47.000 [err] Bug:     tor(_start+0x29) [0x55fcc4b00ec9] (on Tor 0.3.5.0-alpha-dev b8a2bdbdc8c46776)
Aborted (core dumped)

Unfortunately since this is with the ORPort rather than the ControlPort I can't provide a simple telnet demo. If you need repro steps just let me know and I can come up with a demo.

Child Tickets

Change History (5)

comment:1 Changed 6 weeks ago by nickm

Milestone: Tor: 0.3.5.x-final
Owner: set to nickm
Severity: NormalBlocker
Status: newaccepted

comment:2 Changed 6 weeks ago by nickm

Closed #27481 as a duplicate.

comment:3 Changed 6 weeks ago by nickm

I bet b5fddbd24144a94580e50886cd07a82968a1b86c is the problem here.

comment:4 Changed 6 weeks ago by nickm

I think the patch for here is to revert b5fddbd24144a94580e50886cd07a82968a1b86c ,and then to work on a better solution with #27451.

comment:5 Changed 6 weeks ago by nickm

Resolution: fixed
Status: acceptedclosed

dgoulet confirms the fix; I've merged it as 22e24031452d57852e83738bacfff012439f0258

Note: See TracTickets for help on using tickets.