Opened 8 months ago

Closed 8 months ago

#27504 closed enhancement (duplicate)

TBB:some NoScript 10.x setting restored on launch

Reported by: mfD1TuzasD32GvaI3mh6 Owned by: tbb-team
Priority: Low Milestone:
Component: Applications/Tor Browser Version:
Severity: Minor Keywords: TBB noscript browser quantum
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After TBB went to 8.0 NoScript(NS) got upgarded to 10.x. This is all great, coz I love FF Quantum & NS 10.x. However settings for each NS category (default,trusted,untrusted) gets reset to default values on each startup. Since each of those categories in default gives site more permissions than I would like to, I need to remember to tweak NS on every launch before visiting any site to stay secure. Trusted category is most severe as I use this setting to fetch only 1st party script and if I forget to configure and simply give Trusted category to a site, suddenly I am pulling fonts, 3rd party scripts, media and more.

Child Tickets

Change History (1)

comment:1 Changed 8 months ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #27175.

Note: See TracTickets for help on using tickets.