#27520 closed defect (duplicate)

Fix regression breaking user agent spoofing

Reported by: cypherpunks3 Owned by: tbb-team
Priority: Very High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

From https://bugzilla.mozilla.org/show_bug.cgi?id=1404608, a patch was added that breaks user agent spoofing. This patch is small and reverting it will fix this issue. Please fix this regression.

The main problem is that users who have JS disabled are largely protected from platform fingerprinting. The lack of spoofing makes it so that even those users can no longer hide their platform. I do not want to be the only person who shows as using Linux on some of the sites I visit.

Please fix this issue.

Child Tickets

Change History (3)

comment:1 Changed 12 months ago by cypherpunks3

Should I install an extension to manually spoof user agent in the mean time?

comment:2 Changed 12 months ago by cyberpunks

Possible duplicate of #26146.

comment:3 Changed 12 months ago by traumschule

Resolution: duplicate
Status: newclosed

yes, duplicate. we should also merge the discussion from #27495 into #26146.

Note: See TracTickets for help on using tickets.