Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#27571 closed defect (not a bug)

Bandwidth values in top relays and relay view

Reported by: juga Owned by: metrics-team
Priority: Medium Milestone:
Component: Metrics/Website Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Clicking on Top Relays [0] it says Top Relays by Consensus Weight

then the column that is shown is Advertised Bandwidth.
Is it actually top relays by advertised bandwidth?.

Would be easy to add a consensus weight column?

Is it total number shown down left regarding the relays displayed or the total regarding the query?

In a relay view [1], consensus weight does not have units, but dir-spec says it's in KB [2]. Would be useful to add the unit there?.
Is it took into account that consensus weight values are published in KB (not KiB, not B)?

[0] https://metrics.torproject.org/rs.html#toprelays
[1] https://metrics.torproject.org/rs.html#details/BC630CBBB518BE7E9F4E09712AB0269E9DC7D626
[2] https://gitweb.torproject.org/torspec.git/tree/dir-spec.txt#n2337

Child Tickets

Change History (5)

comment:1 Changed 11 months ago by juga

Component: MetricsMetrics/Website

Assign subcomponent

comment:2 in reply to:  description ; Changed 11 months ago by karsten

Replying to juga:

Clicking on Top Relays [0] it says Top Relays by Consensus Weight

then the column that is shown is Advertised Bandwidth.
Is it actually top relays by advertised bandwidth?.

No, it's top relays by consensus weight.

Would be easy to add a consensus weight column?

I guess so, at least from a data perspective. Unclear whether that would make things easier to understand with yet one more column. But I see your point that the number that is used for ordering is currently not contained in the table.

Is it total number shown down left regarding the relays displayed or the total regarding the query?

I have to guess, but I think it's the total regarding the query. In this case it's the total advertised bandwidth of the top 250 relays by consensus weight.

In a relay view [1], consensus weight does not have units, but dir-spec says it's in KB [2]. Would be useful to add the unit there?.
Is it took into account that consensus weight values are published in KB (not KiB, not B)?

Well, dir-spec says it's "currently kilobytes per second". I don't think that adding a unit would add a lot more clarity. It's a weight that is only used in comparison to all other weights, so that a unit is not necessary.

[0] https://metrics.torproject.org/rs.html#toprelays
[1] https://metrics.torproject.org/rs.html#details/BC630CBBB518BE7E9F4E09712AB0269E9DC7D626
[2] https://gitweb.torproject.org/torspec.git/tree/dir-spec.txt#n2337

Leaving this ticket open for irl to decide whether anything mentioned above needs fixing.

comment:3 in reply to:  2 ; Changed 11 months ago by irl

Resolution: not a bug
Status: newclosed

Replying to karsten:

Replying to juga:

Would be easy to add a consensus weight column?

I guess so, at least from a data perspective. Unclear whether that would make things easier to understand with yet one more column. But I see your point that the number that is used for ordering is currently not contained in the table.

There are lots of columns that we could display here, but the view can get very crowded very quickly. At some point we should add the ability to choose what columns you would like to see and we could make consensus weight a default to display in the top relays view but this is going to take a big chunk of work to do.

Is it total number shown down left regarding the relays displayed or the total regarding the query?

I have to guess, but I think it's the total regarding the query. In this case it's the total advertised bandwidth of the top 250 relays by consensus weight.

Yes, this is regarding the query. Currently these aggregates must be calculated in Relay Search as Onionoo does not provide aggregated queries.

In a relay view [1], consensus weight does not have units, but dir-spec says it's in KB [2]. Would be useful to add the unit there?.
Is it took into account that consensus weight values are published in KB (not KiB, not B)?

Well, dir-spec says it's "currently kilobytes per second". I don't think that adding a unit would add a lot more clarity. It's a weight that is only used in comparison to all other weights, so that a unit is not necessary.

Consensus weights themselves are really only used to produce ratios. It is convenient if we have a unit we can think and reason about them with, but I don't think there is anything in tor that is actually interpreting consensus weights directly without considering the total consensus weights in the network.

comment:4 in reply to:  3 Changed 11 months ago by juga

Replying to irl:

There are lots of columns that we could display here, but the view can get very crowded very quickly. At some point we should add the ability to choose what columns you would like to see and we could make consensus weight a default to display in the top relays view but this is going to take a big chunk of work to do.

That would be great.

In a relay view [1], consensus weight does not have units, but dir-spec says it's in KB [2]. Would be useful to add the unit there?.
Is it took into account that consensus weight values are published in KB (not KiB, not B)?

Well, dir-spec says it's "currently kilobytes per second". I don't think that adding a unit would add a lot more clarity. It's a weight that is only used in comparison to all other weights, so that a unit is not necessary.

Consensus weights themselves are really only used to produce ratios. It is convenient if we have a unit we can think and reason about them with, but I don't think there is anything in tor that is actually interpreting consensus weights directly without considering the total consensus weights in the network.

Still, the consensus weight is proportional to the measured bandwidths and observed bandwidths. It'd be useful to have same proportions when we'll create graphs comparing measured bandwidth and consensus weight, for instance.

comment:5 Changed 11 months ago by irl

If you have two values with identical units and you take a ratio of those, the ratio has no units anyway.

Relay Search uses Onionoo as its backend which does not currently contain votes (#16843) and so the comparison between cw and observed/advertised bandwidths isn't currently possible to implement in Relay Search.

I can see there is room for improvement but we need to make some big changes to enable this improvement, otherwise we end up with complicated spaghetti code as in Relay Search's aggregated search feature.

Note: See TracTickets for help on using tickets.