Opened 21 months ago

Closed 4 months ago

#27572 closed defect (worksforme)

metrics.tpo glossary bandwidth terms

Reported by: juga Owned by: metrics-team
Priority: High Milestone:
Component: Metrics/Website Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Is bandwidth history the descriptor observed-bandwidth[1]?.

Since there are several bandwidth terms and they can be confusing, it might be useful to add a link to the spec in the definition?, or add where it comes from?.

Maybe that should be also done for advertised bandwidth and consesus weight?

[1] https://gitweb.torproject.org/torspec.git/tree/dir-spec.txt#n427

Child Tickets

Change History (11)

comment:1 Changed 21 months ago by juga

Component: - Select a componentMetrics/Statistics
Owner: set to metrics-team

Assign component

comment:2 Changed 21 months ago by juga

comment:3 Changed 21 months ago by karsten

Here's where the different values come from:

However, I'm not sure if the glossary is the right place for including dir-spec links or for mentioning descriptor keywords. The glossary is written for folks who need a high level understanding of the concepts. If these definitions are not clear enough, let's phrase them more clearly, but in a way that is as non-technical as it can be.

For everyone else who wants more details how to compute values from Tor descriptors, there's the reproducible metrics page. It's not linked much from Tor Metrics, because it's new. But we're going to link it more very soon.

Does that answer your question and sound like a reasonable plan forward? If not, please suggest what we should change. If yes, please feel free to close the ticket or tell me to do so. Thanks!

comment:4 Changed 21 months ago by irl

A future goal (although I'm not sure how far in the future it will be) is to ensure that the technical definitions for all terms in the Metrics glossary are also in torspec's glossary. torspec is the authoritative source for definitions and the Metrics glossary reproduces those definitions to make them accessible to those wanting to better understand our metrics.

comment:5 Changed 21 months ago by juga

irl, did you already create a ticket to add glossary terms to torspec?.
Should we do that?

comment:6 Changed 21 months ago by irl

I did not yet create the ticket, but I do have the start of a patch.

comment:7 in reply to:  3 ; Changed 21 months ago by juga

Replying to karsten:

For everyone else who wants more details how to compute values from Tor descriptors, there's the reproducible metrics page. It's not linked much from Tor Metrics, because it's new. But we're going to link it more very soon.

thanks, i didn't know about that page, yeah, that's useful, glad that will be linked.

Does that answer your question and sound like a reasonable plan forward? If not, please suggest what we should change. If yes, please feel free to close the ticket or tell me to do so. Thanks!

Yes. The reproducible metrics could be a good place to link to torspec. I think it's not explained there where the consensus weight comes from.

comment:8 in reply to:  7 Changed 21 months ago by irl

Replying to juga:

Yes. The reproducible metrics could be a good place to link to torspec. I think it's not explained there where the consensus weight comes from.

This should really be defined in torspec first. If it is not currently, then this could go into the patch I am making for merging the other metrics terms.

comment:9 Changed 5 months ago by karsten

Component: Metrics/StatisticsMetrics/Website

comment:10 Changed 4 months ago by karsten

Priority: MediumHigh

Changing priority of all defects in Metrics/Website to high to get these resolved soon.

comment:11 Changed 4 months ago by karsten

Resolution: worksforme
Status: newclosed

So, going through the description and comments above I don't see anything that needs to be changed in the glossary. It's written for users, not for developers or researchers. References to a torspec glossary or to dir-spec.txt would probably hurt more than they would help.

We do have the reproducible metrics page for our more technical users who want to understand how we compute our numbers. That page already references keywords from dir-spec.txt by name, it just doesn't contain hyperlinks. I also don't see an easy way to link to dir-spec.txt. If we go by line number, then we'll have to update that page whenever somebody modifies dir-spec.txt. If dir-spec.txt were an HTML document with anchors that would work, but that's not the case.

Frankly, I don't think that there's anything left to do here. Of course, it does make sense to harmonize the metrics glossary with what's in the torspec glossary. But that's not what this ticket is about. Closing as worksforme.

Note: See TracTickets for help on using tickets.