Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#27591 closed enhancement (wontfix)

TB: Offer an option to disable updates on first start

Reported by: traumschule Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Launcher Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by traumschule)

A blind windows user told on IRC that TB 8.0 does not work with NVda Screenreader (#27503) and that TB 7.5 updated itself although updates were disabled.

Please do something with Tor browser 8.0 for Windows acessibility. It's not accessible to blind users of NVda Screanreader.
I tried install 7.5 but after disable update it started updater. I dont know how i can properly disable it.

and left shortly after. Maybe the option was not obvious enough at first.

We could (try to improve usability for blind users and) add a checkbox on the first Tor Launcher screen to disable updates.

Child Tickets

Change History (7)

comment:1 Changed 9 months ago by gk

Resolution: worksforme
Status: newclosed

The problem is that you need to be faster with flipping the update relevant preference than the update check is done. And that check is performed during the start-up. So, you need to either set the preference before you start the first time by editing a preference file in the editor (I guess prefs.js in the profile should suffice). But I guess flipping the pref in the browser and then deleting the downloaded update before it gets applied should work as well (but I have not tested that part).

So, I think that's actually a WORKSFORME.

comment:2 Changed 9 months ago by teor

Here are some steps that should work:

  1. Download and start Tor Browser
  2. Once Tor Browser has started, turn off your wifi (or unplug your ethernet)
  3. Turn off updating
  4. Close Tor Browser
  5. Turn your wifi back on
  6. Open Tor Browser

Here are some more steps that should work:

  1. As an admin user, copy Tor Browser to the Applications folder
  2. As a non-admin user, open Tor Browser

Tor Browser cannot update when it is opened by a non-admin user. It will try to update, and fail.

comment:3 Changed 9 months ago by traumschule

Component: Applications/Tor BrowserApplications/Tor Launcher
Description: modified (diff)
Resolution: worksforme
Status: closedreopened
Summary: Usability for blind users / TB 7.5 updates itself although updates are disabledTB: Offer an option to disable updates on first start
Type: defectenhancement

Rebranding this to keep above valuable input visible.

comment:4 Changed 9 months ago by gk

Resolution: wontfix
Status: reopenedclosed

I don't think we should do that within Tor Browser given that the reason this is needed is exceptional. We should fix the underlying bug instead and if that's not easily possible provide instructions for affected users otherwise.

traumschule: please open a new ticket next time. Integers are cheap I've heard and reopening a ticket and changing its description is confusing.

comment:5 Changed 9 months ago by traumschule

Currently working on #13005 - could we add an environment variable to disable updates?

Last edited 9 months ago by traumschule (previous) (diff)

comment:6 Changed 9 months ago by gk

#27503 is the one that triggered the request, see bug description. Re environment variable I am not convinced. What would be the benefit of having extra code + providing a good explanation for above all Windows users to use it and disable updates compared to providing a good explanation for above all Windows users to disable updates?

comment:7 in reply to:  6 Changed 9 months ago by traumschule

Replying to gk:

What would be the benefit of having extra code + providing a good explanation for above all Windows users to use it and disable updates compared to providing a good explanation for above all Windows users to disable updates?

A user in #tor commented "this is too much microsoft for me" because they decided not to update to TB 8 because of a popular issue.

Just sharing, i have no opinion about it.

Last edited 9 months ago by traumschule (previous) (diff)
Note: See TracTickets for help on using tickets.