Opened 10 months ago

Last modified 2 weeks ago

#27602 new defect

iis windows authentication prompt not showing up

Reported by: Schnuffles Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability-website
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Good day,
i am running a sharepoint server (IIS Webserver). To access the page a windows authentication prompt is showing up, asking me for username and password. But if i want to access the page via tor-browser the popup is not showing up. It just tells me „401 UNAUTHORIZED“. I already tried to fix this in the settings but i didnt get any solution right now.
Sorry for my bad english and best regards,
Schnuffles

Child Tickets

Change History (3)

comment:1 Changed 10 months ago by gk

Keywords: ff68-esr tbb-usability-website added; login prompt IIS popup removed

I think we patched that out in #12974 due to https://bugzilla.mozilla.org/show_bug.cgi?id=1046421 as this can leak a bunch of details of Tor users. However, it seems Mozilla fixed the most obvious issue in https://hg.mozilla.org/mozilla-central/rev/bf5fd6a7021e. So, it might be worth reconsidering this decision. Putting this on our ff68-esr radar but we could audit this earlier if we get to it

comment:2 Changed 3 weeks ago by gk

Before enabling authentication here again we should be sure to double-check https://bugzilla.mozilla.org/show_bug.cgi?id=1261591 which blocks the fixed bug.

comment:3 in reply to:  2 Changed 2 weeks ago by gk

Keywords: ff68-esr removed

Replying to gk:

Before enabling authentication here again we should be sure to double-check https://bugzilla.mozilla.org/show_bug.cgi?id=1261591 which blocks the fixed bug.

Yeah, this is still an issue. Thus, we need to keep this disabled for now, alas. :( (Or we fix it up ourselves which could be considerable work)

Note: See TracTickets for help on using tickets.