Opened 2 months ago

Closed 2 months ago

#27677 closed defect (implemented)

document minimum required python versions

Reported by: catalyst Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-doc
Cc: Actual Points:
Parent ID: Points:
Reviewer: dgoulet Sponsor:

Description

It looks like at least sometimes we end up using python constructs that require python >=2.7 or >= 3.1. (See #27675 for an example.) We should document this somewhere, possibly in doc/HACKING.

Child Tickets

Change History (3)

comment:1 Changed 2 months ago by rl1987

Status: newneeds_review

comment:2 Changed 2 months ago by dgoulet

Reviewer: dgoulet
Status: needs_reviewmerge_ready

lgtm;

comment:3 Changed 2 months ago by nickm

Resolution: implemented
Status: merge_readyclosed

squashed and merged!

Note: See TracTickets for help on using tickets.