Opened 6 months ago

Closed 6 months ago

Last modified 4 months ago

#27705 closed defect (fixed)

What to change on stem release 1.7

Reported by: juga Owned by: juga
Priority: Medium Milestone: sbws: 1.0.x-final
Component: Core Tor/sbws Version:
Severity: Normal Keywords: sbws-1.0-must-closed-moved-20181128
Cc: pastly, juga, teor Actual Points:
Parent ID: #27107 Points:
Reviewer: Sponsor:

Description

When #26914 is fixed:

  • when stem 1.7 is in pypi:
    • change setup.py to add stem >= 1.7 dependency and remove dependency links
    • change tox.ini to remove install_command and use tox default
  • when stem 1.7 is in Debian sid
    • change INSTALL.md to recommend installing from Debian
    • update Debian source to:
      • remove the patch
      • change stem dependency to 1.7
  • when stem 1.7 is in Debian stretch-backports
    • create sbws package for Debian stretch-backports

Child Tickets

TicketStatusOwnerSummaryComponent
#27975closedjugaCreate new sbws release based on stem 1.7.0Core Tor/sbws

Change History (6)

comment:1 Changed 6 months ago by juga

Parent ID: #27107

assign parent

comment:2 Changed 6 months ago by pastly

When the new stem hits, we should release sbws 0.7.1. If a Debian package is going to be updated, it should be updated with 0.7.1.

comment:3 Changed 6 months ago by juga

I plan to also include #27976, and therefore i think the new sbws release should be 0.8.0, since there's a major cli behavior change

comment:4 Changed 6 months ago by juga

comment:5 Changed 6 months ago by pastly

Resolution: fixed
Status: assignedclosed

Child is closed, closing this too.

comment:6 Changed 4 months ago by teor

Keywords: sbws-1.0-must-closed-moved-20181128 added
Milestone: sbws 1.0 (MVP must)sbws: 1.0.x-final

Move all closed sbws 1.0 must tickets to sbws 1.0.x-final

Note: See TracTickets for help on using tickets.