#27759 closed defect (duplicate)

3 Bugs in Tor relay logs

Reported by: fcornu Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: 0.3.4.8
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: #26434 Points:
Reviewer: Sponsor:

Description (last modified by teor)

Greetings, all :)

Got these in my relay's log this morning

Sep 18 06:00:58.000 [warn] connection_dir_finished_flushing(): Bug: Emptied a dirserv buffer, but it's still spooling! (on Tor 0.3.4.8 )
Sep 18 06:00:58.000 [warn] connection_mark_for_close_internal_(): Bug: Duplicate call to connection_mark_for_close at ../src/or/directory.c:5201 (first at ../src/or/main.c:1210) (on Tor 0.3.4.8 )
Sep 18 06:00:58.000 [warn] tor_bug_occurred_(): Bug: ../src/or/connection.c:841: connection_mark_for_close_internal_: This line should not have been reached. (Future instances of this warning will be silenced.) (on Tor 0.3.4.8 )
Sep 18 06:00:58.000 [warn] Bug: Line unexpectedly reached at connection_mark_for_close_internal_ at ../src/or/connection.c:841. Stack trace: (on Tor 0.3.4.8 )
Sep 18 06:00:58.000 [warn] Bug:     /usr/bin/tor(log_backtrace+0x44) [0x5605ad9f8354] (on Tor 0.3.4.8 )
Sep 18 06:00:58.000 [warn] Bug:     /usr/bin/tor(tor_bug_occurred_+0xb9) [0x5605ada132f9] (on Tor 0.3.4.8 )
Sep 18 06:00:58.000 [warn] Bug:     /usr/bin/tor(connection_dir_finished_flushing+0xab) [0x5605ad9acd3b] (on Tor 0.3.4.8 )
Sep 18 06:00:58.000 [warn] Bug:     /usr/bin/tor(connection_handle_read+0xb7a) [0x5605ad98586a] (on Tor 0.3.4.8 )
Sep 18 06:00:58.000 [warn] Bug:     /usr/bin/tor(+0x53afe) [0x5605ad8c3afe] (on Tor 0.3.4.8 )
Sep 18 06:00:58.000 [warn] Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x6a0) [0x7f5fe7ebb5a0] (on Tor 0.3.4.8 )
Sep 18 06:00:58.000 [warn] Bug:     /usr/bin/tor(do_main_loop+0x265) [0x5605ad8c5e95] (on Tor 0.3.4.8 )
Sep 18 06:00:58.000 [warn] Bug:     /usr/bin/tor(tor_run_main+0x1175) [0x5605ad8c8685] (on Tor 0.3.4.8 )
Sep 18 06:00:58.000 [warn] Bug:     /usr/bin/tor(tor_main+0x3a) [0x5605ad8c04ba] (on Tor 0.3.4.8 )
Sep 18 06:00:58.000 [warn] Bug:     /usr/bin/tor(main+0x19) [0x5605ad8c0229] (on Tor 0.3.4.8 )
Sep 18 06:00:58.000 [warn] Bug:     /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1) [0x7f5fe67172e1] (on Tor 0.3.4.8 )
Sep 18 06:00:58.000 [warn] Bug:     /usr/bin/tor(_start+0x2a) [0x5605ad8c027a] (on Tor 0.3.4.8 )

As they appeared quite on the same time, I thought I'd report them in a single ticket, they may be related.

Relay is 'wardsback'

Child Tickets

Change History (2)

comment:1 Changed 11 months ago by fcornu

Apologies for the poor stack trace formatting

comment:2 Changed 11 months ago by teor

Description: modified (diff)
Milestone: Tor: unspecified
Parent ID: #26434
Resolution: duplicate
Status: newclosed

Thanks for this bug report!

This looks like a duplicate of #26434, but this line is not in the other bug report:

Sep 18 06:00:58.000 [warn] Bug: Line unexpectedly reached at connection_mark_for_close_internal_ at ../src/or/connection.c:841. Stack trace: (on Tor 0.3.4.8 )

The code hasn't changed, so it is possible that the original reporter missed the third bug.

Note: See TracTickets for help on using tickets.