Opened 2 months ago

Closed 2 months ago

#27780 closed defect (duplicate)

Tor doesn't start after upgrade on MaxOSX 10.9

Reported by: gra Owned by: tbb-team
Priority: Very High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi,

This morning after the upgrade tor doesn't start.
It open a window with: "Tor unexpectedly exited. This migh be due to a bug... etc"

Clicking on 'Copy Tor Log To Clipboard' said 'Copy Complete. 0 Tor log message are ready to be pasted...', but don't paste anything...

A crash report is available on the mac:

here a copy:

Process: tor.real [768]
Path: /Users/USER/*/TorBrowser.app/Contents/MacOS/Tor/tor.real
Identifier: tor.real
Version: ???
Code Type: X86-64 (Native)
Parent Process: firefox [766]
Responsible: firefox [766]
User ID: 503

Date/Time: 2018-09-19 08:46:14.726 +0200
OS Version: Mac OS X 10.9.5 (13F1911)
Report Version: 11
Anonymous UUID: 67FC80E0-9EE1-1943-AEE6-6DC70AFE9B45

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Dyld Error Message:

Symbol not found: _mach_approximate_time
Referenced from: /Users/USER/*/TorBrowser.app/Contents/MacOS/Tor/tor.real
Expected in: /usr/lib/libSystem.B.dylib

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 dyld 0x00007fff6616a09d dyld_fatal_error + 1
1 dyld 0x00007fff6616cdf6 dyld::fastBindLazySymbol(ImageLoader, unsigned long) + 171
2 libdyld.dylib 0x00007fff906b52dd dyld_stub_binder_ + 13
3 ??? 0x0000000104e5c030 0 + 4377133104
4 tor.real 0x0000000104b2d95e tor_run_main + 94
5 tor.real 0x0000000104b9b8b6 tor_main + 70
6 tor.real 0x0000000104a6f65b main + 27
7 tor.real 0x0000000104a6f634 start + 52

Thread 0 crashed with X86 Thread State (64-bit):

rax: 0x00007fff6619edb0 rbx: 0x00007f87e8403b90 rcx: 0x0000000000000000 rdx: 0x0000000000000000
rdi: 0x00007fff6619ef20 rsi: 0x0000000000000000 rbp: 0x00007fff5b1914f0 rsp: 0x00007fff5b1914d8

r8: 0x00007fff66189b8c r9: 0x0000000000000000 r10: 0x00007fff5b191266 r11: 0x00007fff6619ef20

r12: 0x0000000000000000 r13: 0x0000000000000000 r14: 0x00007fff6619ef20 r15: 0x0000000000000000
rip: 0x00007fff6616a09d rfl: 0x0000000000000246 cr2: 0x0000000105f8e000


Logical CPU: 2
Error Code: 0x00000000
Trap Number: 3

Binary Images:

0x104a6e000 - 0x104e5bcc7 +tor.real (???) <C2959D63-1711-3983-A908-C63276915B95> /Users/USER/*/TorBrowser.app/Contents/MacOS/Tor/tor.real
0x104f84000 - 0x104fc2ff7 +libevent-2.1.6.dylib (7.2) <CD222822-C9B1-3CB0-A736-CF75F2B8D98E> /Users/USER/*/TorBrowser.app/Contents/MacOS/Tor/libevent-2.1.6.dylib

0x7fff66169000 - 0x7fff6619c887 dyld (239.5) <1D3130FE-FE7E-3C4C-8E74-EB51895B6BA5> /usr/lib/dyld
0x7fff8b068000 - 0x7fff8b069ffb libremovefile.dylib (33) <3543F917-928E-3DB2-A2F4-7AB73B4970EF> /usr/lib/system/libremovefile.dylib
0x7fff8b0f9000 - 0x7fff8b0faff7 libsystem_blocks.dylib (63) <FB856CD1-2AEA-3907-8E9B-1E54B6827F82> /usr/lib/system/libsystem_blocks.dylib
0x7fff8b0fb000 - 0x7fff8b104ffb libsystem_notify.dylib (121.20.1) <9B34B4FE-F5AD-3F09-A5F0-46AFF3571323> /usr/lib/system/libsystem_notify.dylib
0x7fff8b119000 - 0x7fff8b15bff7 libauto.dylib (185.5) <F45C36E8-B606-3886-B5B1-B6745E757CA8> /usr/lib/libauto.dylib
0x7fff8c14f000 - 0x7fff8c154fff libmacho.dylib (845) <1D2910DF-C036-3A82-A3FD-44FF73B5FF9B> /usr/lib/system/libmacho.dylib
0x7fff8ce7e000 - 0x7fff8ce88fff libcommonCrypto.dylib (60049) <8C4F0CA0-389C-3EDC-B155-E62DD2187E1D> /usr/lib/system/libcommonCrypto.dylib
0x7fff8cf29000 - 0x7fff8cf30ff8 liblaunch.dylib (842.92.1) <A40A0C7B-3216-39B4-8AE0-B5D3BAF1DA8A> /usr/lib/system/liblaunch.dylib
0x7fff8cf6f000 - 0x7fff8cf96ffb libsystem_info.dylib (449.1.4) <12CD9E42-8CEE-3A8D-B006-F8A6EB98804D> /usr/lib/system/libsystem_info.dylib
0x7fff8de3d000 - 0x7fff8de45fff libsystem_dnssd.dylib (522.92.3) <1418DF66-01BE-3A87-8553-09EAA945F4FE> /usr/lib/system/libsystem_dnssd.dylib
0x7fff8de46000 - 0x7fff8de47fff libsystem_sandbox.dylib (278.11.2) <0C93EB23-7364-3670-B511-212A7A524695> /usr/lib/system/libsystem_sandbox.dylib
0x7fff8e628000 - 0x7fff8e62aff7 libquarantine.dylib (71) <7A1A2BCB-C03D-3A25-BFA4-3E569B2D2C38> /usr/lib/system/libquarantine.dylib
0x7fff8e658000 - 0x7fff8e65aff3 libsystem_configuration.dylib (596.15) <4998CB6A-9D54-390A-9F57-5D1AC53C135C> /usr/lib/system/libsystem_configuration.dylib
0x7fff8f26d000 - 0x7fff8f26efff libunc.dylib (28) <62682455-1862-36FE-8A04-7A6B91256438> /usr/lib/system/libunc.dylib
0x7fff8fb88000 - 0x7fff8fb8eff7 libsystem_platform.dylib (24.90.1) <3C3D3DA8-32B9-3243-98EC-D89B9A1670B3> /usr/lib/system/libsystem_platform.dylib
0x7fff8fb8f000 - 0x7fff8fbaaff7 libsystem_malloc.dylib (23.10.1) <A695B4E4-38E9-332E-A772-29D31E3F1385> /usr/lib/system/libsystem_malloc.dylib
0x7fff8fd20000 - 0x7fff8fd31ff7 libsystem_asl.dylib (217.1.4) <655FB343-52CF-3E2F-B14D-BEBF5AAEF94D> /usr/lib/system/libsystem_asl.dylib
0x7fff8fedd000 - 0x7fff8ff2bfff libcorecrypto.dylib (161.1) <F3973C28-14B6-3006-BB2B-00DD7F09ABC7> /usr/lib/system/libcorecrypto.dylib
0x7fff90143000 - 0x7fff90148ff7 libunwind.dylib (35.3) <78DCC358-2FC1-302E-B395-0155B47CB547> /usr/lib/system/libunwind.dylib
0x7fff906b4000 - 0x7fff906b7ff7 libdyld.dylib (239.5) <CAE7A50D-F156-3D47-81C0-DC41EB975D38> /usr/lib/system/libdyld.dylib
0x7fff90bd8000 - 0x7fff90c07fd2 libsystem_m.dylib (3047.16) <B7F0E2E4-2777-33FC-A787-D6430B630D54> /usr/lib/system/libsystem_m.dylib
0x7fff90fac000 - 0x7fff91159f27 libobjc.A.dylib (551.1) <AD7FD984-271E-30F4-A361-6B20319EC73B> /usr/lib/libobjc.A.dylib
0x7fff9115a000 - 0x7fff9115aff7 libkeymgr.dylib (28) <3AA8D85D-CF00-3BD3-A5A0-E28E1A32A6D8> /usr/lib/system/libkeymgr.dylib
0x7fff911a8000 - 0x7fff91231fef libsystem_c.dylib (997.90.5) <889AA3F9-121C-3985-8B1D-5E908C5693BC> /usr/lib/system/libsystem_c.dylib
0x7fff91254000 - 0x7fff9127bff7 libsystem_network.dylib (241.4) <0D630D53-C772-3EC5-8257-EFB0ACCE3153> /usr/lib/system/libsystem_network.dylib
0x7fff916e1000 - 0x7fff91733fff libc++.1.dylib (120) <4F68DFC5-2077-39A8-A449-CAC5FDEE7BDE> /usr/lib/libc++.1.dylib
0x7fff93638000 - 0x7fff9365cfff libxpc.dylib (300.90.2) <AB40CD57-F454-3FD4-B415-63B3C0D5C624> /usr/lib/system/libxpc.dylib
0x7fff94b55000 - 0x7fff94b5cffb libcopyfile.dylib (103.92.1) <CF29DFF6-0589-3590-834C-82E2316612E8> /usr/lib/system/libcopyfile.dylib
0x7fff95479000 - 0x7fff9547aff7 libDiagnosticMessagesClient.dylib (100) <4CDB0F7B-C0AF-3424-BC39-495696F0DB1E> /usr/lib/libDiagnosticMessagesClient.dylib
0x7fff95848000 - 0x7fff9584fff7 libsystem_pthread.dylib (53.1.4) <AB498556-B555-310E-9041-F67EC9E00E2C> /usr/lib/system/libsystem_pthread.dylib
0x7fff96421000 - 0x7fff96422ff7 libSystem.B.dylib (1197.1.1) <72A98ACC-7606-3AD5-82AF-02D4EBBD4F02> /usr/lib/libSystem.B.dylib
0x7fff97833000 - 0x7fff9785cff7 libc++abi.dylib (49.1) <21A807D3-6732-3455-B77F-743E9F916DF0> /usr/lib/libc++abi.dylib
0x7fff97a3d000 - 0x7fff97a57fff libdispatch.dylib (339.92.1) <C4E4A18D-3C3B-3C9C-8709-A4270D998DE7> /usr/lib/system/libdispatch.dylib
0x7fff97a5c000 - 0x7fff97a78ff7 libsystem_kernel.dylib (2422.115.15) <34ABAF79-E147-3C34-B05D-46A566E689CC> /usr/lib/system/libsystem_kernel.dylib
0x7fff97a79000 - 0x7fff97a7dff7 libcache.dylib (62) <BDC1E65B-72A1-3DA3-A57C-B23159CAAD0B> /usr/lib/system/libcache.dylib
0x7fff97b59000 - 0x7fff97b5dff7 libsystem_stats.dylib (93.90.3) <2304C7C2-BE45-35DE-BCC6-707D61B7AE7E> /usr/lib/system/libsystem_stats.dylib
0x7fff9867b000 - 0x7fff9868cff7 libz.1.dylib (53) <42E0C8C6-CA38-3CA4-8619-D24ED5DD492E> /usr/lib/libz.1.dylib
0x7fff986a4000 - 0x7fff986abfff libcompiler_rt.dylib (35) <4CD916B2-1B17-362A-B403-EF24A1DAC141> /usr/lib/system/libcompiler_rt.dylib

External Modification Summary:

Calls made by other processes targeting this process:

task_for_pid: 0
thread_create: 0
thread_set_state: 0

Calls made by this process:

task_for_pid: 0
thread_create: 0
thread_set_state: 0

Calls made by all processes on this machine:

task_for_pid: 484
thread_create: 0
thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=76.3M resident=44.2M(58%) swapped_out_or_unallocated=32.1M(42%)
Writable regions: Total=17.5M written=80K(0%) resident=148K(1%) swapped_out=0K(0%) unallocated=17.3M(99%)

REGION TYPE VIRTUAL
=========== =======
Kernel Alloc Once 4K
MALLOC 9396K
MALLOC (admin) 16K
STACK GUARD 56.0M
Stack 8192K
VM_ALLOCATE 8K
DATA 884K
LINKEDIT 67.1M
TEXT 9436K
shared memory 4K
=========== =======
TOTAL 150.4M

Child Tickets

Attachments (2)

Screen Shot 2018-09-19 at 8.46.54 AM.png (58.4 KB) - added by gra 2 months ago.
tor.real_2018-09-19-084615_Macintosh-58b035f4a342.crash (8.7 KB) - added by gra 2 months ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 2 months ago by gk

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team
Resolution: duplicate
Status: newclosed
Version: Tor: unspecified

Duplicate of #27482. We are about to address this issue with the release of Tor Browser 8.0.1. A workaround until that one is ready (should be tomorrow) is to resort to the alpha release: https://www.torproject.org/projects/torbrowser.html.en#downloads-alpha

Note: See TracTickets for help on using tickets.