Opened 6 months ago

Closed 2 weeks ago

#27784 closed defect (duplicate)

chutney/tools/test-network.sh works fine but failing transmission!

Reported by: teor Owned by: teor
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: teor Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Moved from https://github.com/torproject/chutney/commit/36fc77e3a1047714210b7d3040977352c184339f#commitcomment-30558981

Hi,
chutney/tools/test-network.sh works fine but failing transmission!
Whats the problem could be?
Is the issues of onion urls? I couldn't able to reach to the .onion it is trying to connect.
Please see the log below:

test-network.sh: using CHUTNEY_DNS_CONF '/dev/null'
test-network.sh: no $TOR_DIR, chutney will use $CHUTNEY_TOR and $CHUTNEY_TOR_GENCERT as tor binary paths, or search $PATH for tor binary names
test-network.sh: $CHUTNEY_PATH not valid, using this script's location
test-network.sh: Setting $CHUTNEY_TOR to the standard binary name in PATH
test-network.sh: Setting $CHUTNEY_TOR_GENCERT to the standard binary name in PATH
test-network.sh: Using $CHUTNEY_TOR: 'tor' and $CHUTNEY_TOR_GENCERT: 'tor-gencert'
Using Python 2.7.12
Sending SIGINT to nodes
Waiting for nodes to finish.
Removing stale lock file for test000a ...
Removing stale lock file for test001a ...
Removing stale lock file for test002a ...
bootstrap-network.sh: bootstrapping network: bridges+hs-v2
Using Python 2.7.12
NOTE: creating '/home/aakanksha/chutney/tools/./../net/nodes.1537347299', linking to '/home/aakanksha/chutney/tools/./../net/nodes'
Creating identity key /home/aakanksha/chutney/net/nodes/000a/keys/authority_identity_key for test000a with tor-gencert --create-identity-key --passphrase-fd 0 -i /home/aakanksha/chutney/net/nodes/000a/keys/authority_identity_key -s /home/aakanksha/chutney/net/nodes/000a/keys/authority_signing_key -c /home/aakanksha/chutney/net/nodes/000a/keys/authority_certificate -m 12 -a 127.0.0.1:7000
Creating identity key /home/aakanksha/chutney/net/nodes/001a/keys/authority_identity_key for test001a with tor-gencert --create-identity-key --passphrase-fd 0 -i /home/aakanksha/chutney/net/nodes/001a/keys/authority_identity_key -s /home/aakanksha/chutney/net/nodes/001a/keys/authority_signing_key -c /home/aakanksha/chutney/net/nodes/001a/keys/authority_certificate -m 12 -a 127.0.0.1:7001
Creating identity key /home/aakanksha/chutney/net/nodes/002a/keys/authority_identity_key for test002a with tor-gencert --create-identity-key --passphrase-fd 0 -i /home/aakanksha/chutney/net/nodes/002a/keys/authority_identity_key -s /home/aakanksha/chutney/net/nodes/002a/keys/authority_signing_key -c /home/aakanksha/chutney/net/nodes/002a/keys/authority_certificate -m 12 -a 127.0.0.1:7002
Creating identity key /home/aakanksha/chutney/net/nodes/003ba/keys/authority_identity_key for test003ba with tor-gencert --create-identity-key --passphrase-fd 0 -i /home/aakanksha/chutney/net/nodes/003ba/keys/authority_identity_key -s /home/aakanksha/chutney/net/nodes/003ba/keys/authority_signing_key -c /home/aakanksha/chutney/net/nodes/003ba/keys/authority_certificate -m 12 -a 127.0.0.1:7003
Using Python 2.7.12
Starting nodes

Using Python 2.7.12
test000a is running with PID 6746
test001a is running with PID 6749
test002a is running with PID 6752
test003ba is running with PID 6755
test004r is running with PID 6758
test005r is running with PID 6761
test006r is running with PID 6764
test007r is running with PID 6767
test008br is running with PID 6770
test009c is running with PID 6789
test010bc is running with PID 6800
test011h is running with PID 6819
12/12 nodes are running
Waiting 20 seconds for a consensus containing relays to be generated...
Running 1 verify rounds...
Using Python 2.7.12
Verifying data transmission: (retrying for up to 60 seconds)
Connecting:
Exit to 127.0.0.1:4747 via client localhost:9009
Exit to 127.0.0.1:4747 via client localhost:9010
HS to quynxpiivmezm6mg.onion:5858 (127.0.0.1:4747) via client localhost:9009
Transmitting Data:

Connecting:
Exit to 127.0.0.1:4747 via client localhost:9009
Exit to 127.0.0.1:4747 via client localhost:9010
HS to quynxpiivmezm6mg.onion:5858 (127.0.0.1:4747) via client localhost:9009
Transmitting Data:

Connecting:
Exit to 127.0.0.1:4747 via client localhost:9009
Exit to 127.0.0.1:4747 via client localhost:9010
HS to quynxpiivmezm6mg.onion:5858 (127.0.0.1:4747) via client localhost:9009
Transmitting Data:

Connecting:
Exit to 127.0.0.1:4747 via client localhost:9009
Exit to 127.0.0.1:4747 via client localhost:9010
HS to quynxpiivmezm6mg.onion:5858 (127.0.0.1:4747) via client localhost:9009
Transmitting Data:

Connecting:
Exit to 127.0.0.1:4747 via client localhost:9009
Exit to 127.0.0.1:4747 via client localhost:9010
HS to quynxpiivmezm6mg.onion:5858 (127.0.0.1:4747) via client localhost:9009
Transmitting Data:

Connecting:
Exit to 127.0.0.1:4747 via client localhost:9009
Exit to 127.0.0.1:4747 via client localhost:9010
HS to quynxpiivmezm6mg.onion:5858 (127.0.0.1:4747) via client localhost:9009
Transmitting Data:

Connecting:
Exit to 127.0.0.1:4747 via client localhost:9009
Exit to 127.0.0.1:4747 via client localhost:9010
HS to quynxpiivmezm6mg.onion:5858 (127.0.0.1:4747) via client localhost:9009
Transmitting Data:

Connecting:
Exit to 127.0.0.1:4747 via client localhost:9009
Exit to 127.0.0.1:4747 via client localhost:9010
HS to quynxpiivmezm6mg.onion:5858 (127.0.0.1:4747) via client localhost:9009
Transmitting Data:

Connecting:
Exit to 127.0.0.1:4747 via client localhost:9009
Exit to 127.0.0.1:4747 via client localhost:9010
HS to quynxpiivmezm6mg.onion:5858 (127.0.0.1:4747) via client localhost:9009
Transmitting Data:

Connecting:
Exit to 127.0.0.1:4747 via client localhost:9009
Exit to 127.0.0.1:4747 via client localhost:9010
HS to quynxpiivmezm6mg.onion:5858 (127.0.0.1:4747) via client localhost:9009
Transmitting Data:

Connecting:
Exit to 127.0.0.1:4747 via client localhost:9009
Exit to 127.0.0.1:4747 via client localhost:9010
HS to quynxpiivmezm6mg.onion:5858 (127.0.0.1:4747) via client localhost:9009
Transmitting Data:

Connecting:
Exit to 127.0.0.1:4747 via client localhost:9009
Exit to 127.0.0.1:4747 via client localhost:9010
HS to quynxpiivmezm6mg.onion:5858 (127.0.0.1:4747) via client localhost:9009
Transmitting Data:

Transmission: Failure
Set CHUTNEY_DEBUG to diagnose.
Completed 1 of 1 verify rounds.
Using Python 2.7.12
Sending SIGINT to nodes
Waiting for nodes to finish.
Removing stale lock file for test000a ...
Removing stale lock file for test001a ...
Removing stale lock file for test002a ...
Removing stale lock file for test003ba ...
Removing stale lock file for test004r ...
Removing stale lock file for test005r ...
Removing stale lock file for test006r ...
Removing stale lock file for test007r ...
Removing stale lock file for test008br ...
Removing stale lock file for test009c ...
Removing stale lock file for test010bc ...
Removing stale lock file for test011h ...
Summary: nodes
Detail: chutney/tools/warnings.sh /home/aakanksha/chutney/tools/./../net/nodes.1537347299
Warning: You are running Tor as root. You don't need to, and you probably shouldn't. Number: 12

Child Tickets

TicketStatusOwnerSummaryComponent
#27783closedteorChutney: Authorities are getting created but relays are not getting configured!Core Tor/Chutney

Attachments (2)

nodes.1537347299.rar (317.9 KB) - added by sreenivassadhu@… 6 months ago.
log
nodes.1537347299.2.rar (317.9 KB) - added by sreenivassadhu@… 6 months ago.
Log with 15 nodes of chutney config

Download all attachments as: .zip

Change History (8)

comment:1 in reply to:  description Changed 6 months ago by teor

Replying to teor:

chutney/tools/test-network.sh works fine but failing transmission!

Please copy and paste the exact command you are running.

Whats the problem could be?

It's hard to say from this log.

Can you attach a compressed tar archive of /home/aakanksha/chutney/tools/./../net/nodes.1537347299 to this ticket?
It has all the detailed logs.

Is the issues of onion urls? I couldn't able to reach to the .onion it is trying to connect.

chutney sets up a separate tor network on your local machine.
If you're using Tor Browser to try to reach the .onion, it uses the public Tor network.

comment:3 Changed 6 months ago by sreenivassadhu@…

Please copy and paste the exact command you are running.

chutney/tools$ ./test-network.sh --offline

This command is to test the tor network and setting up path for tor.
Later, it tests, configures (with 12 nodes - authorities, relays and clients), starts and verify the network.

Final result/output i ma getting is : Tranmission Failure? What could be the reason?

(chutney sets up a separate tor network on your local machine.
If you're using Tor Browser to try to reach the .onion, it uses the public Tor network)
Okay! I understand!

comment:4 Changed 6 months ago by teor

Can you attach a compressed tar archive of /home/aakanksha/chutney/tools/./../net/nodes.1537347299 to this ticket?
It has all the detailed logs.

I need to see the detailed logs to help you.

Changed 6 months ago by sreenivassadhu@…

Attachment: nodes.1537347299.rar added

log

comment:5 Changed 6 months ago by sreenivassadhu@…

Hi, Could u able to go through the logs?

Why chutney/tools/test-network.sh could not establish successful transfer.

It uses 12 nodes (including all DA's, Relays, Clients,etc)

Changed 6 months ago by sreenivassadhu@…

Attachment: nodes.1537347299.2.rar added

Log with 15 nodes of chutney config

comment:6 Changed 2 weeks ago by teor

Component: Core Tor/ChutneyCore Tor/Tor
Resolution: duplicate
Status: assignedclosed

I am sorry that I ran out of time to help you with these issues.

This issue is caused by bug #24198, which was fixed more than a year ago.
Please upgrade to the latest tor version.

Note: See TracTickets for help on using tickets.