#27818 closed defect (duplicate)

0.3.5.2-alpha undefined reference to `get_uint32' on ARM device.

Reported by: Prada Owned by:
Priority: Medium Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: undefined, reference, error, 0.3.5.2-alpha, tor-arm
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I already have tor running well on gl-ar150 router.
Also have another device, a Raspberry Pi configured to run openwrt.
I can do ssh and mount device files remotely to both.
I wish to run tor on the latter Pi device (but the ar-150 repository is device specific and won't work on the Pi). The Pi is a minimal install and won't run the make command but I have another Pi of the same type on which I am trying to compile tor, the binary might work. (Raspbian GNU/Linux" VERSION="7 (wheezy)").

Problem, how to install tor
https://tor.stackexchange.com/questions/75/how-can-i-install-tor-from-the-source-code-in-the-git-repository


Notes on what I did
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install git build-essential automake libevent-dev libssl-dev
git clone https://git.torproject.org/tor.git
ChangeLog gives version as 0.3.5.2-alpha
chmod +x autogen.sh
sudo ./autogen.sh
sudo make
./configure
sudo apt-get install asciidoc
./configure
make

Error resulted as follows

CC src/tools/tor_runner.o
AR src/tools/libtorrunner.a
CC src/app/main/tor_main.o
CCLD src/app/tor

src/lib/libtor-crypt-ops.a(src_lib_libtor_crypt_ops_a-aes_openssl.o): In function `aes_set_iv':
/home/pi/tor/src/lib/crypt_ops/aes_openssl.c:399: undefined reference to `get_uint32'
/home/pi/tor/src/lib/crypt_ops/aes_openssl.c:400: undefined reference to `get_uint32'
/home/pi/tor/src/lib/crypt_ops/aes_openssl.c:401: undefined reference to `get_uint32'
/home/pi/tor/src/lib/crypt_ops/aes_openssl.c:402: undefined reference to `get_uint32'
collect2: ld returned 1 exit status
Makefile:6918: recipe for target 'src/app/tor' failed
make[1]: * [src/app/tor] Error 1
make[1]: Leaving directory '/home/pi/tor'
Makefile:4580: recipe for target 'all' failed
make:
* [all] Error 2

I suspect a header reference is missing. I can collect the detailed output if necessary and will try to attach partial terminal output from the compile.

Child Tickets

Attachments (1)

compile.txt (53.3 KB) - added by Prada 12 months ago.
Terminal output

Download all attachments as: .zip

Change History (8)

Changed 12 months ago by Prada

Attachment: compile.txt added

Terminal output

comment:1 Changed 12 months ago by Prada

I see the function is defined in lib/arch/bytes.h but not sure if I should include this at the top of aes_openssl.c as I think it is wise to ask for advice first.

comment:2 Changed 12 months ago by nickm

Component: - Select a componentCore Tor/Tor
Milestone: Tor: 0.3.5.x-final
Status: newneeds_information

Is this a duplicate of #27781?

comment:3 Changed 12 months ago by traumschule

Keywords: tor-arm added

group doc/arm issues
(using tor-arm to avoid mixing with apparmor keyword, maybe there's a better alternative)

comment:5 Changed 12 months ago by Prada

Regarding https://trac.torproject.org/projects/tor/ticket/27781, I tried to update openssl to version 1.1 or greater - problems with file verification resulted - so I couldn't get it and am going to get a new up to date OS.

I did this.
sudo apt-get remove --purge openssl
add to file /etc/apt/sources.list the line
deb httP://http.debian.net/debian wheezy-backports main
sudo apt-get install -t wheezy-backports nginx
This gives
W: GPG error: http://http.debian.net wheezy-backports Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010
sudo apt-get update gives keyring errors and nginx install complains it can't verify the package.

I was unable to fix this with
aptitude install debian-keyring debian-archive-keyring
also tried
sudo gpg --keyserver pgpkeys.mit.edu --recv-key aB48AD6246925553
This reports...
sudo gpg --keyserver pgpkeys.mit.edu --recv-key 8B48AD6246925553
gpg: directory `/root/.gnupg' created
gpg: new configuration file `/root/.gnupg/gpg.conf' created
gpg: WARNING: options in `/root/.gnupg/gpg.conf' are not yet active during this run
gpg: keyring `/root/.gnupg/secring.gpg' created
gpg: keyring `/root/.gnupg/pubring.gpg' created
gpg: requesting key 46925553 from hkp server pgpkeys.mit.edu
gpgkeys: key 8B48AD6246925553 not found on keyserver
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0
I tried a reboot and update still gives NO_PUBKEY and can't verify the package.
sudo apt-get install -t wheezy-backports nginx
WARNING: The following packages cannot be authenticated!

nginx-common nginx-full nginx

So as I can't yet install a good recent version of nginx or openssl I am getting a new up to date version of debian.

Is it not possible to make an install of tor that includes source code for all cryptographic packages?
I had similar problems with early versions of pgp, files not available and when they are located the downloads taking several tries to get through. Why these critical files that can't be verified?

Will update the link suggested.
https://trac.torproject.org/projects/tor/wiki/doc/arm

comment:6 Changed 12 months ago by Prada

Sorry for the duplicate post.

update: removed the duplicate comment

Last edited 12 months ago by traumschule (previous) (diff)

comment:7 Changed 12 months ago by Prada

I installed the New linux version which although it took a while was worth it.

PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"

I couldn't install asciidoc as insufficient space on the 8GB memory card.

The compile went OK with no errors.

Tor also installs using apt on version 9 without problem and tests out OK.

I'll try to port one or other to the chaos calmer router.

Still problems with keys using backports to try the tor browser, but that is a separate issue.

comment:8 Changed 12 months ago by nickm

Resolution: duplicate
Status: needs_informationclosed

I am pretty sure that this is a duplicate of #27781; please reopen this ticket if the fix we just merged for that one doesn't fix it for you.

Note: See TracTickets for help on using tickets.