#27829 closed defect (duplicate)

Bug: Non-fatal assertion !(status == HS_CLIENT_FETCH_HAVE_DESC) failed in retry_all_socks_conn_waiting_for_desc at ../src/feature/hs/hs_client.c:279

Reported by: traumschule Owned by:
Priority: Medium Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: regression?, tor-hs
Cc: dgoulet, asn Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This trace appeared several times in today's log, assumingly the amount corresponds to the number of configured onion services. No relay.

Sep 23 00:00:56.000 [notice] Tor 0.3.5.1-alpha-dev opening new log file.
Sep 23 01:27:56.000 [notice] {HEARTBEAT} Heartbeat: Tor's uptime is 1 day 23:54 hours, with 37 circuits open. I've sent 121.54 MB and received 1.02 GB.
Sep 23 01:27:56.000 [notice] {HEARTBEAT} Average packaged cell fullness: 58.689%. TLS write overhead: 4%
Sep 23 01:27:56.000 [notice] {HEARTBEAT} Our onion services received 39 v2 and 898 v3 INTRODUCE2 cells and attempted to launch 944 rendezvous circuits.
Sep 23 10:56:54.000 [notice] {GENERAL} Your system clock just jumped 31462 seconds forward; assuming established circuits no longer work.
Sep 23 10:57:23.000 [warn] {BUG} tor_bug_occurred_(): Bug: ../src/feature/hs/hs_client.c:279: retry_all_socks_conn_waiting_for_desc: Non-fatal assertion !(status == HS_CLIENT_FETCH_HAVE_DESC) failed. (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug: Non-fatal assertion !(status == HS_CLIENT_FETCH_HAVE_DESC) failed in retry_all_socks_conn_waiting_for_desc at ../src/feature/hs/hs_client.c:279. Stack trace: (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /usr/bin/tor(log_backtrace_impl+0x5e) [0x665cae] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /usr/bin/tor(tor_bug_occurred_+0xbd) [0x66157d] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /usr/bin/tor(hs_client_dir_info_changed+0xce) [0x55b38e] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /usr/bin/tor(router_dir_info_changed+0x34) [0x57be74] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /usr/bin/tor(networkstatus_set_current_consensus+0x41d) [0x5743dd] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /usr/bin/tor(connection_dir_reached_eof+0xf69) [0x545329] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /usr/bin/tor(connection_handle_read+0x829) [0x5f7999] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /usr/bin/tor(+0x42909) [0x4c4909] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /usr/lib/i386-linux-gnu/libevent-2.1.so.6(+0x2091b) [0xb7d8991b] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /usr/lib/i386-linux-gnu/libevent-2.1.so.6(event_base_loop+0x4d1) [0xb7d8a3b1] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /usr/bin/tor(tor_libevent_run_event_loop+0x30) [0x605000] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /usr/bin/tor(do_main_loop+0x228) [0x4c6bb8] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /usr/bin/tor(tor_run_main+0x10d5) [0x4c9375] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /usr/bin/tor(tor_main+0x3f) [0x4c134f] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /usr/bin/tor(main+0x32) [0x4c0ec2] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /lib/i386-linux-gnu/libc.so.6(__libc_start_main+0xf1) [0xb77219a1] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:23.000 [warn] {BUG} Bug:     /usr/bin/tor(+0x3ef1e) [0x4c0f1e] (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:57:30.000 [notice] {CIRC} Your network connection speed appears to have changed. Resetting timeout to 60s after 18 timeouts and 1000 buildtimes.
Sep 23 10:58:15.000 [warn] {BUG} tor_bug_occurred_(): Bug: ../src/feature/hs/hs_client.c:279: retry_all_socks_conn_waiting_for_desc: Non-fatal assertion !(status == HS_CLIENT_FETCH_HAVE_DESC) failed. (on Tor 0.3.5.1-alpha-dev )
Sep 23 10:58:15.000 [warn] {BUG} Bug: Non-fatal assertion !(status == HS_CLIENT_FETCH_HAVE_DESC) failed in retry_all_socks_conn_waiting_for_desc at ../src/feature/hs/hs_client.c:279. Stack trace: (on Tor 0.3.5.1-alpha-dev )
<trace repeated several times>

Child Tickets

Attachments (1)

tor.info.27829.scrubbed.log (722.9 KB) - added by traumschule 10 months ago.
scrubbed info log

Download all attachments as: .zip

Change History (3)

Changed 10 months ago by traumschule

Attachment: tor.info.27829.scrubbed.log added

scrubbed info log

comment:1 Changed 10 months ago by nickm

Milestone: Tor: 0.3.5.x-final

comment:2 Changed 10 months ago by asn

Resolution: duplicate
Status: newclosed

Duplicate of #27410.

You have your Tor configured as an onion service and using it as a client as well?

Note: See TracTickets for help on using tickets.