Opened 11 months ago

Last modified 6 months ago

#27845 reopened defect

Tor Browser window height is is off by some pixels if bookmark toolbar and icons are available

Reported by: monmire Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-fingerprinting-resolution, tbb-8.0-issues, tbb-regression
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

— Platform: MacOS desktop computer

— Change the default Tor Browser 8.0.1 window size on MacOS desktop platforms to match the default Tor Browser 8.0.1 window sizes on Linux and Windows desktop platforms so that the default Tor Browser 8.0.1 window size is identical on MacOS, Linux, and Windows desktop platforms.

— In the Tor Browser 8.0 upgrade from version 7.5.6, the Tor Browser team decreased the default Tor Browser window size on MacOS desktop platforms from 1000 Wide x 1000 High to 1000 Wide x 0998 High.

— In Tor Browser 8.0 and 8.0.1, if the default Tor Browser window size on MacOS (1000 Wide x 0998 High) desktop platforms is smaller than the default Tor Browser window size on Linux (1000 Wide x 1000 High) and Windows (1000 Wide x 1000 High) desktop platforms, an adversary more easily can identify, track, and deanonymize Tor Browser 8.0.1 clients that are using MacOS desktop platforms.

Child Tickets

Change History (26)

comment:1 Changed 11 months ago by catalyst

Component: ApplicationsApplications/Tor Browser
Keywords: tbb-fingerprinting added; Tor Browser 8.0.1 default window size varies across platforms removed
Owner: set to tbb-team

comment:2 Changed 11 months ago by gk

Keywords: tbb-fingerprinting-resolution added; tbb-fingerprinting removed
Priority: Very HighHigh
Severity: CriticalNormal
Status: newneeds_information
Version: Tor: unspecified

Does this happen with a clean, new Tor Browser 8 (you could drag one to your desktop and start Tor Browser from there for testing purposes? And previously, with Tor Browser 7 this was a non-issue? Which macOS system are you on?

comment:3 in reply to:  2 Changed 11 months ago by monmire

Does this happen with a clean, new Tor Browser 8 (you could drag one to your desktop and start Tor Browser from there for testing purposes?

Yes, this happens with a clean new Tor Browser 8.0, 8.0.1, 8.02, and 8.5a2.

And previously, with Tor Browser 7 this was a non-issue?

Yes, previously, with Tor Browser 7.5.6 this was a non-issue.

Which macOS system are you on?

macOS 10.10.5, iMac24 Intel, desktop computer.

Last edited 10 months ago by monmire (previous) (diff)

comment:4 Changed 11 months ago by mcs

#27910 is a duplicate.

comment:5 Changed 11 months ago by monmire

When Tor Browser 8.0.2 is using preferred configuration:1, described below, the browser window size is width:1000 x height:998. However, when Tor Browser 7.5.6 is using the same identical preferred configuration:1, the Tor Browser 7.5.6 window size is 1000x1000. I think Tor Browser 8.0.2, using preferred configuration:1 should not have browser window size:1000x998, but instead should have browser window size:1000x1000, as in Tor Browser 7.5.6.

Tor Browser 7.5.6, using the following preferred configuration:1, has browser window size:1000x1000:

  1. In the Customize page, Bookmarks Toolbar Items is visible in the space between the dotted lines.
  2. Horizontal Bookmarks Toolbar is visible beneath Address Bar.
  3. Saved bkmarks and bkmarks folders are visible in horizontal Bookmarks Toolbar beneath Address Bar.
  4. All other browser settings affecting browser window size have original default configuration.

Tor Browser 8.0.2, using the same identical preferred configuration:1, has browser window size:1000x998:

  1. In the Customize page, Bookmarks Toolbar Items is visible in the space between the dotted lines.
  2. Horizontal Bookmarks Toolbar is visible beneath Address Bar.
  3. Saved bkmarks and bkmarks folders are visible in horizontal Bookmarks Toolbar beneath Address Bar.
  4. All other browser settings affecting browser window size have original default configuration.

Tor Browser 8.0.2, using the following alternative configuration:2, has browser window size:1000x1000:

  1. In the Customize page, Bookmarks Toolbar Items is visible in Overflow Menu.
  2. Empty horizontal Bookmarks Toolbar is visible beneath Address Bar.
  3. Saved bkmarks and bkmarks folders are not visible in horizontal Bookmarks Toolbar beneath Address Bar.
  4. All other browser settings affecting browser window size have original default configuration.

Tor Browser 8.0.2, using the following alternative configuration:3, has browser window size:1000x1000:

  1. In the Customize page, Bookmarks Toolbar Items is visible in Address Bar.
  2. Empty horizontal Bookmarks Toolbar is visible beneath Address Bar.
  3. Saved bkmarks and bkmarks folders are not visible in horizontal Bookmarks Toolbar beneath Address Bar.
  4. All other browser settings affecting browser window size have original default configuration.

Desired result:
Tor Browser 8.0.2, using the aforementioned preferred configuration:1, should have browser window size:1000x1000 and should not have browser window size:1000x998.

Last edited 10 months ago by monmire (previous) (diff)

comment:6 in reply to:  2 Changed 10 months ago by monmire

Replying to gk:

Does this happen with a clean, new Tor Browser 8 (you could drag one to your desktop and start Tor Browser from there for testing purposes? And previously, with Tor Browser 7 this was a non-issue? Which macOS system are you on?

In the top line of ticket #27845, the term needs_information appears. Does this mean I need to provide more information in addition to the new information in comment:5? If the answer to this question is, "yes", what specific additional information should I provide?

Last edited 10 months ago by monmire (previous) (diff)

comment:7 Changed 10 months ago by gk

Keywords: tbb-8.0-issues tbb-regression added
Status: needs_informationassigned

It seems there is a regression in case you have the bookmarks toolbar enabled, putting it on our radar.

comment:8 in reply to:  7 Changed 10 months ago by monmire

Replying to gk:

It seems there is a regression in case you have the bookmarks toolbar enabled, putting it on our radar.

OK. Thank you

comment:10 in reply to:  9 Changed 10 months ago by monmire

https://bugzilla.mozilla.org/show_bug.cgi?id=1418537 is the upstream bug.

Thank you very much for the link.

Last edited 10 months ago by monmire (previous) (diff)

comment:11 Changed 10 months ago by monmire

In Tor Browser 8.0.3, the same identical regression present in Tor Browser 8.0.2, as described in comment:5, still persists.

Last edited 10 months ago by monmire (previous) (diff)

comment:12 Changed 8 months ago by monmire

Tor Browser 8.0.4 (Apple MacOS) has default screen resolution 1000 Wide x 1000 High with all browser settings affecting screen resolution in their default-standard settings.

After selecting View/Toolbars/✓Bookmarks Toolbar, the screen resolution changes to 1000 Wide x 0990 High.

I first noticed a similar regression, 1000 Wide x 0998 High, in Tor Browser 8.0.

Neither the previous regression 1000 Wide x 0998 High, nor the current regression 1000 Wide x 0990 High existed in Tor Browser 7. See comment:5

Screen resolutions in Tor Browser 7 and Tor Browser 8 with identical configuration View/Toolbars/✓Bookmarks Toolbar:

1000 Wide x 1000 High — Tor Browser 7.5.6
1000 Wide x 0998 High — Tor Browser 8.0, 8.0.1, 8.0.2, 8.0.3
1000 Wide x 0990 High — Tor Browser 8.0.4


Let's fix this regression so that when Tor Browser has configuration View/Toolbars/✓Bookmarks Toolbar, the screen resolution will be 1000 Wide x 1000 High, identical to screen resolution 1000 Wide x 1000 High in Tor Browser 7.5.6 with the same configuration View/Toolbars/✓Bookmarks Toolbar.

Platform: Mac OS X 10.10.5 Yosemite on Apple iMac24 Intel desktop pc.

Last edited 8 months ago by monmire (previous) (diff)

comment:13 Changed 8 months ago by monmire

After installing and using Tor Browser 8.0.4 for a short period, the height of the Bookmarks Toolbar and/or the height of the Address Bar and/or the height of the Tab Bar apparently contracted by a combined total of 10 pixels with no configuration input from me, resulting in a most ideal change in the browser screen resolution, changing from 1000 Wide x 990 High to 1000 Wide x 1000 High, with configuration View/Toolbars/✓Bookmarks Toolbar.

I suspect gk, boklm, and/or the tbb team might deserve credit for this screen-resolution fix/correction. Whoever might deserve credit, I respectfully and sincerely thank you all.

comment:14 Changed 8 months ago by gk

Resolution: fixed
Status: assignedclosed

Glad that it works for you. We did not implement a fix directly. But maybe switching to the Rust based style system somehow solves that? Closing this for now. Please reopen if the problem comes back/still persists. Thanks.

comment:15 Changed 6 months ago by monmire

Resolution: fixed
Status: closedreopened

The problem recurred after upgrading from TB 8.0.4 to TB 8.0.5.

With neither bookmarks nor bookmarks-folders appearing in the enabled Bookmarks Toolbar, the screen size is wide:1000 x high:1000.

However, dragging "Bookmarks Toolbars Items" from the Customize panel or the Overflow Menu panel into the Bookmarks Toolbar changes screen size to wide:1000 x high:0998.


Desired result: with bookmarks and bookmarks-folders visible in the Bookmarks Toolbar, screen size should be wide:1000 x high:1000.

Last edited 6 months ago by monmire (previous) (diff)

comment:16 in reply to:  14 Changed 6 months ago by monmire

Replying to gk:

Glad that it works for you. We did not implement a fix directly. But maybe switching to the Rust based style system somehow solves that? Closing this for now. Please reopen if the problem comes back/still persists. Thanks.

I reopened fixed defect #27845 because the problem recurred after I upgraded from TB 8.0.4 to 8.0.5.

Please see comment:15

comment:17 Changed 6 months ago by Thorin

I didn't realize this had been closed.

The problem is not MacOS specific. It has been happening in Windows7 as well in all 8.* versions. The problem is not the toolbar per se, it is the height/padding/spacing/margin of any icons.

It's been happening since FF57 and Quantum's redesign - see https://github.com/ghacksuserjs/ghacks-user.js/issues/297

comment:18 Changed 6 months ago by monmire

After upgrading from Tor Browser 8.0.5 to 8.0.6, the problem recurred.

Initial screen size was wide:1000 x high:1000 with Bookmarks Toolbar not enabled.

Screen size remained wide:1000 x high1000 after enabling Bookmarks Toolbar, but with no bookmark-folders with text and no individual bookmarks with text appearing in the visible but "empty" Bookmarks Toolbar.

Currently, screen size is wide:1000 x high:0998 with Bookmarks Toolbar enabled and with bookmark-folders with text and individual bookmarks with text appearing in the Bookmarks Toolbar.


Chronological log of steps that caused the following weird behavior in TB:

Upgraded from TB 8.0.5 to 8.0.6 and started TB 8.0.6.

Initial screen size was wide:1000 x high1000 with Bookmarks Toolbar not enabled.

Screen size changed to wide:1000 x high:978 after enabling Bookmarks Toolbar, with bookmark-folders with text and individual bookmarks with text appearing in Bookmarks Toolbar.

Screen size changed to wide:1000 x high:998 after quitting and restarting TB, with bookmark-folders with text and individual bookmarks with text appearing in Bookmarks Toolbar.

Screen size changed to wide:1000 x high:1020 after disabling Bookmarks Toolbar.

Screen size changed to wide:1000 x high:1000 after restarting TB, with Bookmarks Toolbar disabled.

Screen size changed to wide:1000 x high:998 after enabling Bookmarks Toolbar with bookmark-folders with text and individual bookmarks with text appearing in Bookmarks Toolbar.


Desired result: screen size wide:1000 x high:1000 with Bookmarks Toolbar enabled, and bookmark-folders with text and individual bookmarks with text appearing in Bookmarks Toolbar.

comment:19 in reply to:  14 Changed 6 months ago by monmire

Replying to gk:

Glad that it works for you. We did not implement a fix directly. But maybe switching to the Rust based style system somehow solves that? Closing this for now. Please reopen if the problem comes back/still persists. Thanks.

The problem recurred again after upgrading from Tor Browser 8.0.5 to 8.0.6.

Please see comment:18

comment:20 Changed 6 months ago by monmire

Resolution: fixed
Status: reopenedclosed

On Tor Browser 8.0.6, I discovered a "Customize" configuration that seems to have resolved the issue on my system (MacOS):

Go to main menu (hamburger menu) and select "Customize" to open Customize panel.

Near the bottom of the Customize panel, open the "Density" panel in which the custom option "Normal" is the default setting. Select the custom option: Compact.

After selecting the Compact option, screen size changed from wide:1000 x high:0998 to screen size wide:1000 x high:1000 with Bookmarks Toolbar enabled and with bookmarks-folders with text and individual bookmarks with text appearing in the enabled Bookmarks Toolbar.


Recommendation: the Tor Browser User Manual and/or the Tor FAQ General questions could include information stating the user can/might achieve screen size wide:1000 x high:1000 with the Bookmarks Toolbar enabled and with bookmarks-folders with text and individual bookmarks with text appearing in the enabled Bookmarks Toolbar if the user selects "Customize/Density/Compact".

Last edited 6 months ago by monmire (previous) (diff)

comment:21 in reply to:  17 Changed 6 months ago by monmire

Replying to Thorin:

I didn't realize this had been closed.

The problem is not MacOS specific. It has been happening in Windows7 as well in all 8.* versions. The problem is not the toolbar per se, it is the height/padding/spacing/margin of any icons.

It's been happening since FF57 and Quantum's redesign - see https://github.com/ghacksuserjs/ghacks-user.js/issues/297

I resolved the issue on my system (MacOS)
See comment:20

comment:22 Changed 6 months ago by Thorin

@ monmire. The inner window is only resized when opening a new window (which includes when you start Tor Browser). It is not dynamically resized as you add/remove/change chrome elements

TB 8.06 (windows7)

  • density normal, toolbar on with icons: opens at 1000x996, change density to compact and the inner windows is now 1000x1010
  • new identity at density compact: opens at 1000x998

I do not have MacOS. It *may* be that compact on MacOS achieves 1000x1000 on a new window, but then what happens if the toolbar has no icons (it will change size, and your *fix* will break). And what about all the people who don't use compact theme. This is not a solution, sorry.

The problem is the icon padding and/or margins which change the height of the toolbar, and this happens after the resizing is calculated on the creation of a new window.

comment:23 in reply to:  22 Changed 6 months ago by monmire

Replying to Thorin:

@ monmire. The inner window is only resized when opening a new window (which includes when you start Tor Browser). It is not dynamically resized as you add/remove/change chrome elements

TB 8.06 (windows7)

  • density normal, toolbar on with icons: opens at 1000x996, change density to compact and the inner windows is now 1000x1010
  • new identity at density compact: opens at 1000x998

I do not have MacOS. It *may* be that compact on MacOS achieves 1000x1000 on a new window, but then what happens if the toolbar has no icons (it will change size, and your *fix* will break). And what about all the people who don't use compact theme. This is not a solution, sorry.

The problem is the icon padding and/or margins which change the height of the toolbar, and this happens after the resizing is calculated on the creation of a new window.

This ticket addresses the issue on MacOS, not on Windows 7. I do not know a solution for TB 8.0.6 on Windows 7. Perhaps you could submit a new ticket addressing the issue on Windows 7.

On MacOS, after selecting /Compact setting and with View/Toolbars/Bookmarks Toolbar enabled, but with neither icons nor text appearing in the Bookmarks Toolbar beneath the URL bar, inner screen size remains wide:1000 x high:1000.

However, on MacOS, with /Compact setting and with View/Toolbars/Bookmarks Toolbar not enabled, inner screen size is `wide:1000 x high:1020.

On Mac OS platform, if a user prefers to enable /Bookmarks Toolbar with icons visible in the Bookmarks Toolbar beneath the URL Bar, /Compact appears to be a solution to achieve wide:1000 x high:1000.

In comment:14, gk closed the ticket as "closed defect (fixed)" because the issue on MacOS resolved itself (see comment:13).

In comment:21, I closed the ticket as "closed defect (fixed)" because /Compact resolved the issue on MacOS (not on Windows 7).

comment:24 Changed 6 months ago by Thorin

I was just pointing out that it also affects Windows - as the UPSTREAM bug already listed in this ticket says. A bug that was filed over a year ago, well before your one about MacOS. It doesn't matter if the title of this bug says "MacOS" (because that's what you choose), the problem is identical (i.e inner window height is not rounded to 100s) in Windows, and there is no point in duplicating tickets. The title should have been edited, IMO.

Changing your density to compact doesn't mean the problem has been solved - it still exists by default for end users.

The underlying problem is not OS specific, it is that icons on the toolbar cause the toolbar height to change (compared to a toolbar without icons), and that the algorithm used to calculate the chrome for window sizing, does so before the toolbar is populated, so it can't detect the new height. And this affects more than MacOS. And it has affected Firefox with RFP enabled since FF57, and it has affected all 6 releases of TB v8.* so far (on windows)

I honestly would have brought this (see the bugzilla bug) to attention months ago, but I just assumed gk et al have it on a low priority, and that the viewport solution in ESR68 will suffice. Quite frankly, I'm not concerned, given that Mozilla haven't seemed interested in it either (remember that the OS is already given away, and the problem should be consistent between platforms). Or gk et al have missed the point when glossing over your walls of often repeated text and posts and full quoting of others in replies. You even bombarded the latest blog about the 8.0.6 release with two entries about this. Please, tone it down.

Please don't bother replying to this, especially quoting it all.

Georg, can you sort out the status (and title) of this bug please, thanks

Last edited 6 months ago by Thorin (previous) (diff)

comment:25 Changed 6 months ago by gk

Resolution: fixed
Status: closedreopened
Summary: Tor Browser 8.0.1 - on MacOS desktop platforms, the default Tor Browser window size is 1000 Wide x 0998 High, not 1000 Wide x 1000 High. Is this a defect?Tor Browser window height is is off by some pixels if bookmark toolbar and icons are available

comment:26 Changed 6 months ago by Thorin

I'm not a css junkie, but here goes: all on Windows7 (but I can test on Windows 10, and Linux if needed, but that shouldn't be needed)

TB (new window each instance): no toolbar: always 1000x1000 | empty toolbar: always 1000x1000

  • density can be normal, compact or touch
  • menubar can be on or off
  • extra drag space can be on or off
  • title bar can be on or off
  • theme can be light, dark or default

Now add a no-named folder to the toolbar, i.e no text

  • in touch mode: = adds 8 pixels (making height e.g 992)
  • in normal mode: = OK
  • in compact mode: = OK
  • I never tested touch mode before. I wrongly assumed folders couldn't cause a problem

Now add some text to the folder name, OR add a site icon (no text), OR add text to site icon

  • in touch mode: = adds 8 pixels (to be expected since text increase is less than that)
  • in normal mode: = adds 4 pixels
  • in compact mode: = adds 2 pixels (making height e.g 998)

It's a combination of density, and whether or not text or a site icon exists as to how big the discrepancy is

## Solution

As Samy pointed out ( https://bugzilla.mozilla.org/show_bug.cgi?id=1418537#c3 )

#PersonalToolbar toolbarbutton.bookmark-item:not(.subviewbutton) {
  padding-top: 0 !important;
  padding-bottom: 0 !important;
}

Add that internally to the css (or uggh, create a userChrome.css). Tested on TB8 Win7 (should do the same thing for Mac)

  • blank toolbar: still 1000x1000
  • icon+text
    • normal = OK
    • compact = OK
    • touch = OK

The only drawback is that it does take away the fat-fingers toolbar for touch. It also doesn't fully work on stable FF, so I suspect there have been other changes. I would consider this a decent patch until ESR68

Note: See TracTickets for help on using tickets.