Opened 7 weeks ago

Closed 7 weeks ago

#27863 closed defect (duplicate)

Bootstrap hangs when disconnected

Reported by: atagar Owned by:
Priority: High Milestone:
Component: Core Tor/Tor Version:
Severity: Major Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi network team. When disconnected from the network tor bootstrapping hangs of late...

% cat dummy_torrc 
SocksPort 0
ControlPort 9051
CookieAuthentication 1
ExitPolicy reject *:*
% tor -f dummy_torrc
Sep 25 10:45:09.631 [notice] Tor 0.3.5.2-alpha-dev (git-7d9bea6a773cc18c) running on Linux with Libevent 2.0.21-stable, OpenSSL 1.0.2g, Zlib 1.2.8, Liblzma N/A, and Libzstd N/A.
Sep 25 10:45:09.632 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Sep 25 10:45:09.632 [notice] This version is not a stable Tor release. Expect more bugs than usual.
Sep 25 10:45:09.632 [notice] Read configuration file "/home/atagar/Desktop/stem/dummy_torrc".
Sep 25 10:45:09.634 [notice] Opening Control listener on 127.0.0.1:9051
Sep 25 10:45:09.634 [notice] Opened Control listener on 127.0.0.1:9051
Sep 25 10:45:09.000 [notice] Bootstrapped 0%: Starting
Sep 25 10:45:10.000 [notice] Starting with guard context "default"

[ waited five minutes, didn't get any further ]

^CSep 25 10:50:11.000 [notice] Interrupt: exiting cleanly.

This is of concern to me because when Stem launches a tor instance it waits for a bootstrap message indicating success. As such, tools like tor-prompt hang when not connected to a network.

This once wasn't the case but I'm unsure when it regressed.

Child Tickets

Change History (1)

comment:1 Changed 7 weeks ago by dgoulet

Resolution: duplicate
Status: newclosed

Duplicate of #27849.

Caused by: https://trac.torproject.org/projects/tor/ticket/27849#comment:7

I expect to fix this one quickly in the coming days as it is quite annoying!

Note: See TracTickets for help on using tickets.