#27928 closed defect (fixed)

Refrain from listener rebinding when address families differ

Reported by: rl1987 Owned by:
Priority: High Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version: Tor: 0.3.5.1-alpha
Severity: Normal Keywords: bind port switching regression?
Cc: Actual Points:
Parent ID: #27808 Points:
Reviewer: asn Sponsor:

Description

In retry_listener_ports, we check if port matches exactly and *one* of the addresses is a wildcard address:

2795         const int may_need_rebind =
2796           port_matches_exact && bool_neq(tor_addr_is_null(&wanted->addr),
2797                                          tor_addr_is_null(&conn->addr));

We should also check if address family is the same between old and new listener. If they differ, we don't need to do rebinding. See discussion on #17873.

Child Tickets

Change History (10)

comment:1 Changed 11 months ago by rl1987

Status: newneeds_review

comment:2 Changed 11 months ago by nickm

Keywords: regression? added
Milestone: Tor: unspecifiedTor: 0.3.5.x-final

comment:3 Changed 11 months ago by nickm

Priority: MediumHigh

comment:4 Changed 10 months ago by rl1987

Parent ID: #27808

comment:5 Changed 10 months ago by asn

Status: needs_reviewneeds_revision

Hello,

I did a review, I basically had a suggestion about comments.

Also, the appveyor CI is failing, do you know what's up with that? (since appveyor on master looks ok). We can't merge appveyor fails.

comment:6 Changed 10 months ago by rl1987

Appveyor failure was #27943 - now fixed.

New pull request with comment and rebased branch: https://github.com/torproject/tor/pull/404

comment:7 Changed 10 months ago by rl1987

Status: needs_revisionneeds_review

comment:8 Changed 10 months ago by dgoulet

Reviewer: asn

comment:9 Changed 10 months ago by asn

Status: needs_reviewmerge_ready

LGTM!

comment:10 Changed 10 months ago by nickm

Resolution: fixed
Status: merge_readyclosed

merged!

Note: See TracTickets for help on using tickets.