#27988 closed defect (not a bug)

connection dissapears

Reported by: yz Owned by: tbb-team
Priority: Immediate Milestone:
Component: Applications/Tor Browser Version:
Severity: Critical Keywords: connection dissapears
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi

Tor Browser on my PC often looses connection, so programms which use proxy 127.0.0.1 and Tor itself has no access to Internet till Tor is shuted down and opened again.

connection is stable - checked by Opera browser that is not using Tor proxy

settings are standart
version 8.0.2
OS - Windows 10 and Ubuntu 17.10
new instance doesn't help

please help

Child Tickets

Change History (7)

comment:1 Changed 13 months ago by yz

i'm waiting
will somebody answer?

or maybe i should leave this message somewhere else?

please advise

comment:2 Changed 13 months ago by gk

Status: newneeds_information

What does "looses connection" mean? What happens in this case if you use Tor Browser?

comment:3 in reply to:  2 Changed 13 months ago by yz

Replying to gk:

What does "looses connection" mean? What happens in this case if you use Tor Browser?

it means Tor Browser at some moment somehow stops connecting to internet and any website i'm trying to load is not loading.

if there is any possibility to get logs of Tor Browser crash, just tell me HOW and i'll get it.

comment:4 Changed 13 months ago by gk

Oh, you mean it is crashing? What makes you believe so? If this happens on Ubuntu as well. What logs do you get if you start Tor Browser in your terminal by ./start-tor-browser.desktop --debug in your Tor Browser directory and Tor Browser stops working?

comment:5 Changed 13 months ago by yz

it seems like it is crashing somewhere inside
but there are no visible signs about crash

i started Tor Browser in terminal now and waiting for "the same moment"

i'll send a reply here if there will be anything

comment:6 Changed 13 months ago by yz

~/**************/tor-browser_ru$ ./start-tor-browser.desktop --debug
Launching './Browser/start-tor-browser --detach --debug'...
Unable to update the static FcBlanks: 0x0600
Unable to update the static FcBlanks: 0x0601
Unable to update the static FcBlanks: 0x0602
Unable to update the static FcBlanks: 0x0603
Unable to update the static FcBlanks: 0x06dd
Unable to update the static FcBlanks: 0x070f
Unable to update the static FcBlanks: 0x2028
Unable to update the static FcBlanks: 0x2029
Unable to update the static FcBlanks: 0xfff9
Unable to update the static FcBlanks: 0xfffa
Unable to update the static FcBlanks: 0xfffb
Oct 12 09:12:35.489 [notice] Tor 0.3.4.8 (git-da95b91355248ad8) running on Linux with Libevent 2.1.8-stable, OpenSSL 1.0.2p, Zlib 1.2.11, Liblzma N/A, and Libzstd N/A.
Oct 12 09:12:35.490 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Oct 12 09:12:35.505 [notice] Read configuration file "/home/**************/tor-browser_ru/Browser/TorBrowser/Data/Tor/torrc-defaults".
Oct 12 09:12:35.527 [notice] Read configuration file "/home/**************/tor-browser_ru/Browser/TorBrowser/Data/Tor/torrc".
Oct 12 09:12:35.701 [notice] Scheduler type KIST has been enabled.
Oct 12 09:12:35.701 [notice] Opening Socks listener on 127.0.0.1:9150
Oct 12 09:12:35.701 [notice] Opening Control listener on 127.0.0.1:9151
Oct 12 09:12:35.000 [notice] Parsing GEOIP IPv4 file /home/**************/tor-browser_ru/Browser/TorBrowser/Data/Tor/geoip.

(firefox:18586): Gtk-WARNING **: Theme parsing error: <data>:1:34: Expected ')' in color definition

(firefox:18586): Gtk-WARNING **: Theme parsing error: <data>:1:77: Expected ')' in color definition
Oct 12 09:12:36.000 [notice] Parsing GEOIP IPv6 file /home/**************/tor-browser_ru/Browser/TorBrowser/Data/Tor/geoip6.
Oct 12 09:12:36.000 [notice] Bootstrapped 0%: Starting
Oct 12 09:12:37.000 [notice] Starting with guard context "default"
Oct 12 09:12:37.000 [notice] Bootstrapped 80%: Connecting to the Tor network
Oct 12 09:12:37.000 [notice] New control connection opened from 127.0.0.1.
Oct 12 09:12:37.000 [notice] New control connection opened from 127.0.0.1.
Oct 12 09:12:37.000 [notice] Bootstrapped 85%: Finishing handshake with first hop
Oct 12 09:12:38.000 [notice] Bootstrapped 90%: Establishing a Tor circuit
1539335558411	addons.webextension.https-everywhere-eff@eff.org	WARN	Please specify whether you want browser_style or not in your browser_action options.
Oct 12 09:12:38.000 [notice] Your Guard d6relay ($*************) is failing more circuits than usual. Most likely this means the Tor network is overloaded. Success counts are 103/163. Use counts are 53/84. 155 circuits completed, 48 were unusable, 5 collapsed, and 182 timed out. For reference, your timeout cutoff is 419 seconds.
1539335558423	addons.webextension.{************}	WARN	Please specify whether you want browser_style or not in your browser_action options.
Oct 12 09:12:38.000 [notice] Your Guard d6relay ($**************) is failing to carry more streams on its circuits than usual. Most likely this means the Tor network is overloaded or your network connection is poor. Use counts are 53/84. Success counts are 104/165. 156 circuits completed, 48 were unusable, 5 collapsed, and 182 timed out. For reference, your timeout cutoff is 419 seconds.
Oct 12 09:12:38.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Oct 12 09:12:38.000 [notice] Bootstrapped 100%: Done
Unable to update the static FcBlanks: 0x0600
Unable to update the static FcBlanks: 0x0601
Unable to update the static FcBlanks: 0x0602
Unable to update the static FcBlanks: 0x0603
Unable to update the static FcBlanks: 0x06dd
Unable to update the static FcBlanks: 0x070f
Unable to update the static FcBlanks: 0x2028
Unable to update the static FcBlanks: 0x2029
Unable to update the static FcBlanks: 0xfff9
Unable to update the static FcBlanks: 0xfffa
Unable to update the static FcBlanks: 0xfffb
Oct 12 09:12:42.000 [notice] New control connection opened from 127.0.0.1.
Oct 12 09:12:43.000 [notice] New control connection opened from 127.0.0.1.
Unable to update the static FcBlanks: 0x0600
Unable to update the static FcBlanks: 0x0601
Unable to update the static FcBlanks: 0x0602
Unable to update the static FcBlanks: 0x0603
Unable to update the static FcBlanks: 0x06dd
Unable to update the static FcBlanks: 0x070f
Unable to update the static FcBlanks: 0x2028
Unable to update the static FcBlanks: 0x2029
Unable to update the static FcBlanks: 0xfff9
Unable to update the static FcBlanks: 0xfffa
Unable to update the static FcBlanks: 0xfffb
Oct 12 09:12:50.000 [warn] Application request to port 110: this port is commonly used for unencrypted protocols. Please make sure you don't send anything you would mind the rest of the Internet reading!
JavaScript error: chrome://global/content/browser-child.js, line 359: NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIWebNavigation.loadURIWithOptions]
JavaScript error: chrome://global/content/browser-child.js, line 359: NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIWebNavigation.loadURIWithOptions]
Unable to update the static FcBlanks: 0x0600
Unable to update the static FcBlanks: 0x0601
Unable to update the static FcBlanks: 0x0602
Unable to update the static FcBlanks: 0x0603
Unable to update the static FcBlanks: 0x06dd
Unable to update the static FcBlanks: 0x070f
Unable to update the static FcBlanks: 0x2028
Unable to update the static FcBlanks: 0x2029
Unable to update the static FcBlanks: 0xfff9
Unable to update the static FcBlanks: 0xfffa
Unable to update the static FcBlanks: 0xfffb
Oct 12 09:23:07.000 [warn] Application request to port 110: this port is commonly used for unencrypted protocols. Please make sure you don't send anything you would mind the rest of the Internet reading!
Oct 12 09:26:55.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~martini at **************. Retrying on a new circuit.
Oct 12 09:26:55.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~martini at **************. Retrying on a new circuit.
Oct 12 09:26:56.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~martini at **************. Retrying on a new circuit.
Oct 12 09:26:57.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~martini at **************. Retrying on a new circuit.
Oct 12 09:26:58.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~martini at **************. Retrying on a new circuit.
Oct 12 09:27:00.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~martini at **************. Retrying on a new circuit.
Oct 12 09:27:01.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~martini at **************. Retrying on a new circuit.
Oct 12 09:27:04.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~martini at **************. Retrying on a new circuit.
Oct 12 09:27:04.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~martini at **************. Retrying on a new circuit.
JavaScript error: resource:///modules/sessionstore/SessionFile.jsm, line 337: Error: _initWorker called too early! Please read the session file from disk first.
Oct 12 09:32:34.000 [notice] New control connection opened from 127.0.0.1.
Unable to update the static FcBlanks: 0x0600
Unable to update the static FcBlanks: 0x0601
Unable to update the static FcBlanks: 0x0602
Unable to update the static FcBlanks: 0x0603
Unable to update the static FcBlanks: 0x06dd
Unable to update the static FcBlanks: 0x070f
Unable to update the static FcBlanks: 0x2028
Unable to update the static FcBlanks: 0x2029
Unable to update the static FcBlanks: 0xfff9
Unable to update the static FcBlanks: 0xfffa
Unable to update the static FcBlanks: 0xfffb
Unable to update the static FcBlanks: 0x0600
Unable to update the static FcBlanks: 0x0601
Unable to update the static FcBlanks: 0x0602
Unable to update the static FcBlanks: 0x0603
Unable to update the static FcBlanks: 0x06dd
Unable to update the static FcBlanks: 0x070f
Unable to update the static FcBlanks: 0x2028
Unable to update the static FcBlanks: 0x2029
Unable to update the static FcBlanks: 0xfff9
Unable to update the static FcBlanks: 0xfffa
Unable to update the static FcBlanks: 0xfffb
Oct 12 09:32:45.000 [warn] Application request to port 110: this port is commonly used for unencrypted protocols. Please make sure you don't send anything you would mind the rest of the Internet reading!
JavaScript error: chrome://global/content/browser-child.js, line 359: NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIWebNavigation.loadURIWithOptions]
Oct 12 09:33:30.000 [notice] Tor has not observed any network activity for the past 431 seconds. Disabling circuit build timeout recording.
Oct 12 09:34:21.000 [notice] Tor now sees network activity. Restoring circuit build timeout recording. Network was down for 482 seconds during 3 circuit attempts.
Oct 12 09:34:22.000 [notice] Your Guard volatile ($**************) is failing to carry more streams on its circuits than usual. Most likely this means the Tor network is overloaded or your network connection is poor. Use counts are 46/64. Success counts are 181/247. 233 circuits completed, 48 were unusable, 4 collapsed, and 210 timed out. For reference, your timeout cutoff is 419 seconds.
Oct 12 09:42:27.000 [warn] Application request to port 110: this port is commonly used for unencrypted protocols. Please make sure you don't send anything you would mind the rest of the Internet reading!
Unable to update the static FcBlanks: 0x0600
Unable to update the static FcBlanks: 0x0601
Unable to update the static FcBlanks: 0x0602
Unable to update the static FcBlanks: 0x0603
Unable to update the static FcBlanks: 0x06dd
Unable to update the static FcBlanks: 0x070f
Unable to update the static FcBlanks: 0x2028
Unable to update the static FcBlanks: 0x2029
Unable to update the static FcBlanks: 0xfff9
Unable to update the static FcBlanks: 0xfffa
Unable to update the static FcBlanks: 0xfffb
Oct 12 09:52:45.000 [warn] Application request to port 110: this port is commonly used for unencrypted protocols. Please make sure you don't send anything you would mind the rest of the Internet reading!
Oct 12 10:02:41.000 [warn] Application request to port 110: this port is commonly used for unencrypted protocols. Please make sure you don't send anything you would mind the rest of the Internet reading!
Oct 12 10:12:20.000 [warn] Application request to port 110: this port is commonly used for unencrypted protocols. Please make sure you don't send anything you would mind the rest of the Internet reading!
Oct 12 10:22:39.000 [warn] Application request to port 110: this port is commonly used for unencrypted protocols. Please make sure you don't send anything you would mind the rest of the Internet reading!
Oct 12 10:27:02.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~coffswifi3 at **************. Retrying on a new circuit.
Oct 12 10:27:02.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~coffswifi3 at **************. Retrying on a new circuit.
Oct 12 10:27:04.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~coffswifi3 at **************. Retrying on a new circuit.
Oct 12 10:27:07.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~coffswifi3 at **************. Retrying on a new circuit.
Oct 12 10:27:07.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~coffswifi3 at **************. Retrying on a new circuit.
Oct 12 10:27:08.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~coffswifi3 at **************. Retrying on a new circuit.
Oct 12 10:27:09.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~coffswifi3 at **************. Retrying on a new circuit.
Oct 12 10:27:09.000 [notice] We tried for 15 seconds to connect to '[scrubbed]' using exit $**************~coffswifi3 at **************. Retrying on a new circuit.
Oct 12 10:32:18.000 [warn] Application request to port 110: this port is commonly used for unencrypted protocols. Please make sure you don't send anything you would mind the rest of the Internet reading!
Oct 12 10:33:37.000 [notice] Tor has not observed any network activity for the past 433 seconds. Disabling circuit build timeout recording.
Oct 12 10:34:18.000 [notice] Tried for 120 seconds to get a connection to [scrubbed]:110. Giving up. (waiting for circuit)
Oct 12 10:35:12.000 [notice] Tried for 120 seconds to get a connection to [scrubbed]:993. Giving up. (waiting for circuit)
Oct 12 10:42:14.000 [notice] Tor now sees network activity. Restoring circuit build timeout recording. Network was down for 950 seconds during 12 circuit attempts.
Oct 12 10:42:31.000 [warn] Application request to port 110: this port is commonly used for unencrypted protocols. Please make sure you don't send anything you would mind the rest of the Internet reading!


while i was preparing this log Tor started to see "network activity" and connection was restored after 8 minutes of disconnect, then all repeated again and now it was 15 minutes of disconnect

comment:7 Changed 13 months ago by gk

Resolution: not a bug
Status: needs_informationclosed

Looking at your logs I don't think this is a Tor Browser bug. Either the Tor relays you are using are flaky or there is someone trying to disrupt/throttle your connection (possibly a censor). At least those would be my first guesses. (And there might not be many exit relays allowing port 110 but I have not checked.)

Note: See TracTickets for help on using tickets.