Opened 9 months ago

Closed 4 months ago

#28013 closed enhancement (duplicate)

run test-network-all in Travis CI

Reported by: catalyst Owned by: catalyst
Priority: High Milestone: Tor: 0.4.1.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: test, chutney, consistency, integration-testing, continuous-integration, tor-ci, postfreeze-ok
Cc: Actual Points:
Parent ID: #29280 Points:
Reviewer: Sponsor:

Description (last modified by teor)

We should run make test-network-all in Travis CI for the tor repository. #27912 tracks the corresponding work for the chutney repository.

Child Tickets

Change History (12)

comment:1 Changed 9 months ago by catalyst

Priority: MediumHigh

comment:2 Changed 9 months ago by catalyst

Looks like it's failing for no obvious reason:
https://travis-ci.org/tlyu/tor/jobs/440345697

comment:3 Changed 9 months ago by nickm

Okay; in this case it looks like two of the authorities didn't start up, for some reason. That reason should be in the logs, but they're not being automatically dumped.

It looks like chutney's diagnostics might not be on track for us to add Chutney to travis right now. Maybe we should improve the diagnostics, and revisit it in 0.3.6?

comment:4 in reply to:  3 ; Changed 9 months ago by catalyst

Replying to nickm:

It looks like chutney's diagnostics might not be on track for us to add Chutney to travis right now. Maybe we should improve the diagnostics, and revisit it in 0.3.6?

That seems reasonable.

comment:5 Changed 8 months ago by catalyst

Milestone: Tor: 0.3.5.x-finalTor: 0.3.6.x-final

comment:6 Changed 8 months ago by teor

Description: modified (diff)
Summary: run test-network in Travis CIrun test-network-all in Travis CI

We should run "make test-network-all" to catch more bugs.

comment:7 in reply to:  4 Changed 8 months ago by teor

Replying to catalyst:

Replying to nickm:

It looks like chutney's diagnostics might not be on track for us to add Chutney to travis right now. Maybe we should improve the diagnostics, and revisit it in 0.3.6?

That seems reasonable.

I added some chutney diagnostic tickets as children of #20647.

comment:8 Changed 8 months ago by teor

I added some chutney diagnostics as part of #27912.

comment:9 Changed 8 months ago by nickm

Milestone: Tor: 0.3.6.x-finalTor: 0.4.0.x-final

Tor 0.3.6.x has been renamed to 0.4.0.x.

comment:10 Changed 5 months ago by nickm

Keywords: postfreeze-ok added

Mark some tickets as postfreeze-ok, to indicate that I think they are okay to accept in 0.4.0 post-freeze. Does not indicate that they are all necessary to do postfreeze.

comment:11 Changed 5 months ago by nickm

Milestone: Tor: 0.4.0.x-finalTor: 0.4.1.x-final

IIUC this is roadmapped for 0.4.1.x

comment:12 Changed 4 months ago by teor

Parent ID: #20647#29280
Resolution: duplicate
Status: assignedclosed

I think this is now a duplicate of #29280.

Note: See TracTickets for help on using tickets.