#28031 closed enhancement (not a bug)

stream isolation

Reported by: sarpedon Owned by:
Priority: Medium Milestone:
Component: Applications Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi!
I want to implement tor stream isolation using stem library.
what approach is suitable for distinguishing between vast variety of streams that come to tor, by a socks5 client such as Tor Browser.
i need to be notified if tor button has assigned different user/pass to that stream, so it belongs to a different tab or requested domain. by the time among all the information i can get from a StreamEvent using stem, non of them helps me to find that what domain request is the source of this stream. is there a way using stem API to do this? Thanks in Advance.

Child Tickets

Change History (3)

comment:1 Changed 13 months ago by atagar

This was asked of me over email as well. Here's the answer I gave...

Hi. Sorry, I don't really understand exactly what you're trying to do.
By 'user/pass' I assume you mean a username/password being
communicated over the stream? Streams are effectively connections made
over tor - the following example gives a basic demonstration on how
you can interact with them.

https://stem.torproject.org/tutorials/examples/exit_used.html

comment:2 Changed 13 months ago by traumschule

Status: newneeds_information

Guess this ticket is asking about https://www.torproject.org/docs/faq#ChoosePathCountries and how domain isolation is implemented in doc/TorBrowser/Hacking#DesignandCoreComponents.
What are possible action points here?

comment:3 Changed 13 months ago by gk

Resolution: not a bug
Status: needs_informationclosed
Version: Tor: unspecified

Not a bug. I think some of our mailing lists like tor-talk or tor-dev are better suited for this kind of question.

Note: See TracTickets for help on using tickets.