Opened 8 months ago

Closed 8 months ago

#28033 closed defect (duplicate)

The IP address of the output node in the connection information window does not match the real output address.

Reported by: notifier Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-circuit-display
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

If you open the incognito tab (CTRL + SHIFT + P) and go to the website whoer.net. The IP address on the website and the IP address which is specified in the connection information window (click on the green lock next to the navigation bar) are different! I consider this a very important issue. I was sure that I go to sites with a different ip. It turned out it was not. Thank.

Child Tickets

Change History (1)

comment:1 Changed 8 months ago by gk

Component: ApplicationsApplications/Tor Browser
Keywords: tbb-circuit-display added; ip exit node removed
Owner: set to tbb-team
Priority: HighMedium
Resolution: duplicate
Status: newclosed

The problem is that the test on that site is loaded over a different circuit than other parts of the website (like favicons) later on and the circuit display only shows the last circuit used. We should fix that circuit display somehow although it is not clear yet, how.

Resolving this as duplicate of #27590.

Note: See TracTickets for help on using tickets.