Opened 9 months ago

Last modified 4 weeks ago

#28045 accepted defect

Start supporting python 3.7, python 3.8, and pypy3.5

Reported by: juga Owned by: juga
Priority: Medium Milestone: sbws: 1.2.x-final
Component: Core Tor/sbws Version:
Severity: Normal Keywords: easy, no-changes-version
Cc: Actual Points:
Parent ID: #29953 Points: 1
Reviewer: Sponsor:

Description


Child Tickets

Change History (11)

comment:1 Changed 9 months ago by juga

Status: assignedneeds_review

comment:2 Changed 9 months ago by juga

Status: needs_reviewaccepted

Travis tries to download python from trusty, which doesn't support python3.7.
No need to support this for now.

comment:3 Changed 8 months ago by teor

Milestone: sbws 1.1

We've deferred this ticket, it can go in sbws 1.1.

comment:4 Changed 8 months ago by teor

Milestone: sbws 1.1sbws 1.2

Milestone renamed

comment:5 Changed 8 months ago by teor

Milestone: sbws 1.2sbws: 1.2.x

Milestone renamed

comment:6 Changed 8 months ago by teor

Milestone: sbws: 1.2.xsbws: 1.2.x-final

Milestone renamed

comment:7 Changed 8 months ago by teor

Milestone: sbws: 1.2.x-finalsbws: unspecified

Milestone renamed

comment:8 Changed 4 months ago by juga

Cc: pastly juga teor removed
Keywords: easy no-changes-version added
Parent ID: #29953

comment:9 Changed 4 months ago by juga

Points: 1

comment:10 Changed 6 weeks ago by teor

Milestone: sbws: unspecifiedsbws: 1.2.x-final

It would be nice to make these changes in sbws 1.2

comment:11 Changed 4 weeks ago by teor

Summary: Start supporting python 3.7Start supporting python 3.7, python 3.8, and pypy3.5

We can test these changes using Travis CI, see #30067.

Note: See TracTickets for help on using tickets.