Opened 14 months ago

Closed 12 months ago

Last modified 11 months ago

#28070 closed defect (fixed)

'Save Image' crashes browser

Reported by: babs4 Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-mobile, tbb-crash
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When long pressing an image I wished to save and tapping 'Save Image', the browser crashed and crashes now upon opening. Also I found a partially-saved image in my Downloads folder; deleting this has no effect on the crashing behavior.

This is on version 60.2.1-Fdroid.

Child Tickets

Change History (6)

comment:1 Changed 14 months ago by gk

Keywords: tbb-crash added
Priority: MediumHigh
Status: newneeds_information

Hm. Which device are you on? Do you get an error message or a popup before/during the crash? If so, what does it say?

comment:2 Changed 14 months ago by gk

I wonder whether #28016 is related here.

comment:3 Changed 14 months ago by babs4

Ok here goes-

In order to 'fix' the crashes-on-startup behavior I had to reset the app by clearing data from Android settings. I just now tried to reproduce the defect by

  1. Navigating to https://en.m.wikipedia.org/wiki/Main_Page
  2. Long pressing a displayed image (a polar bear in this case)
  3. Tapping the 'Image' tab of the popup menu
  4. Tapping 'Save Image'

Nothing happened: no crash, no notification, nothing saved to my internal storage AFAICT.

So I then tried to navigate directly to a .jpg file,

https://upload.wikimedia.org/wikipedia/commons/6/66/Polar_Bear_-_Alaska_%28cropped%29.jpg

, and then following the above steps 2 through 4. Same result (nothing).

There was no 'Browser' error message or dialog when the original defect occurred. Only an 'Android' notification that the Tor Browser Alpha app had closed.

I am running a carrier build of Android 7.1.1 on a Qualcomm ARMv7 Quad-core.

comment:4 Changed 12 months ago by gk

Resolution: fixed
Status: needs_informationclosed

Saving files was broken in previous Tor Browser for Android versions. I have some hope we fixed that with the latest release (8.5a5). Please try that one and reopen the ticket in case you still see the problem you had.

comment:5 Changed 11 months ago by babs4

Have just tested with 8.5a5. Retried the process of comment #3. The browser has not crashed but neither has it downloaded the image (although I was prompted to allow File Access permission for Tor Browser for Android). Tried same process with another image on that page and nothing happens either.

Since browser hasn't crashed will leave ticket status as closed.

comment:6 Changed 11 months ago by gk

What happens with the latest Tor Browser for Android (8.5a6) (FWIW: I guess it will crash on your device. If so, that's #28705 then and will be fixed in the next release)

Note: See TracTickets for help on using tickets.