Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#28133 closed defect (duplicate)

Tor Browser restarts when using Reader View shortcut (ctrl+alt+r)

Reported by: ev9F8itL Owned by: tbb-team
Priority: Low Milestone:
Component: Applications/Tor Browser Version:
Severity: Minor Keywords: tbb-usability, tbb-8.0-issues
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Even if the webpage doesn't support reader view, ctrl+alt+r causes Tor Browser to crash/restart and lose the current session. Clicking on the reader view icon to the right of the URL bar works, however.

Produced on Tor Browser 8.0.2, Debian GNU/Linux 9 (64-bit).

Child Tickets

Change History (8)

comment:1 Changed 13 months ago by gk

Component: - Select a componentApplications/Tor Browser
Keywords: tbb-crash added
Owner: set to tbb-team
Status: newneeds_information

Do you get some useful information in your terminal when Tor Browser crashes if you start it with ./start-tor-browser.desktop --debug? (FWIW: It's not crashing for me on my 64bit Debian system) How did you install Tor Browser? Does this happen with a clean, new one downloaded from our website?

comment:2 Changed 13 months ago by ev9F8itL

I installed Tor Browser by downloading and extracting the .tar.xz file. I run start-tor-browser from the folder.

I tried downloading a fresh package from the website and still have the issue. Here's the output of ./start-tor-browser --debug

Launching './Browser/start-tor-browser --detach --debug'...
Oct 22 23:15:54.012 [notice] Tor 0.3.4.8 (git-da95b91355248ad8) running on Linux with Libevent 2.1.8-stable, OpenSSL 1.0.2p, Zlib 1.2.8, Liblzma N/A, and Libzstd N/A.
Oct 22 23:15:54.012 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Oct 22 23:15:54.012 [notice] Read configuration file "/home/user0/Applications/tor-browser_en-US/Browser/Downloads/tor-browser_en-US/Browser/TorBrowser/Data/Tor/torrc-defaults".
Oct 22 23:15:54.012 [notice] Read configuration file "/home/user0/Applications/tor-browser_en-US/Browser/Downloads/tor-browser_en-US/Browser/TorBrowser/Data/Tor/torrc".
Oct 22 23:15:54.018 [notice] Scheduler type KIST has been enabled.
Oct 22 23:15:54.018 [notice] Opening Socks listener on 127.0.0.1:9150
Oct 22 23:15:54.018 [notice] Opening Control listener on 127.0.0.1:9151
Oct 22 23:15:54.000 [notice] Parsing GEOIP IPv4 file /home/user0/Applications/tor-browser_en-US/Browser/Downloads/tor-browser_en-US/Browser/TorBrowser/Data/Tor/geoip.
Oct 22 23:15:54.000 [notice] Parsing GEOIP IPv6 file /home/user0/Applications/tor-browser_en-US/Browser/Downloads/tor-browser_en-US/Browser/TorBrowser/Data/Tor/geoip6.
Oct 22 23:15:54.000 [notice] Bootstrapped 0%: Starting
Oct 22 23:15:55.000 [notice] Starting with guard context "default"
Oct 22 23:15:55.000 [notice] Bootstrapped 80%: Connecting to the Tor network
Oct 22 23:15:55.000 [notice] New control connection opened from 127.0.0.1.
Oct 22 23:15:55.000 [notice] New control connection opened from 127.0.0.1.
Oct 22 23:15:55.000 [notice] Bootstrapped 85%: Finishing handshake with first hop
1540250155151	addons.webextension.https-everywhere-eff@eff.org	WARN	Please specify whether you want browser_style or not in your browser_action options.
1540250155151	addons.webextension.{73a6fe31-595d-460b-a920-fcc0f8843232}	WARN	Please specify whether you want browser_style or not in your browser_action options.
Oct 22 23:15:55.000 [notice] Bootstrapped 90%: Establishing a Tor circuit
Oct 22 23:15:55.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Oct 22 23:15:55.000 [notice] Bootstrapped 100%: Done
Oct 22 23:15:57.000 [notice] New control connection opened from 127.0.0.1.
Oct 22 23:15:57.000 [notice] New control connection opened from 127.0.0.1.
Oct 22 23:16:03.000 [notice] Owning controller connection has closed -- exiting now.
Oct 22 23:16:03.000 [notice] Catching signal TERM, exiting cleanly.
JavaScript error: chrome://torbutton/content/tor-circuit-display.js, line 436: TypeError: myController is null

comment:3 Changed 13 months ago by ev9F8itL

Forgot to mention that the last three lines of the output I posted are what's relevant; they occur after pressing ctrl+alt+r and before Tor Browser restarts. I omitted what comes afterwards because it's just Tor Browser starting up again.

comment:4 Changed 13 months ago by gk

Keywords: tbb-usability added; ff60-esr tbb-crash removed
Summary: Tor Browser crashes/restarts when using Reader View shortcut (ctrl+alt+r)Tor Browser restarts when using Reader View shortcut (ctrl+alt+r)

That is really weird. I wonder what is mapping this shortcut to a browser restart for you. What locale are you using?

comment:5 Changed 13 months ago by gk

Another question: If you are on a page with reader mode available what shortcut in Tor Browser do you get if you open the view menu (Alt+V)? (there should be an item Enter Reader View + the shortcut for it)

comment:6 Changed 13 months ago by reportUrl

comment:7 in reply to:  6 Changed 13 months ago by gk

Keywords: tbb-8.0-issues added
Resolution: duplicate
Status: needs_informationclosed

Replying to reportUrl:

ticket:27623#comment:4 ;)

Nice find! That indeed explains it. Marking this bug as a duplicate of #27623.

ev9F8itL: I hope we can backport the fix for that bug to the next stable release (we are currently testing it in the alpha series) which should solve your issue.

comment:8 Changed 13 months ago by ev9F8itL

Awesome, thanks.

Last edited 13 months ago by ev9F8itL (previous) (diff)
Note: See TracTickets for help on using tickets.