Opened 11 months ago

Closed 6 months ago

#28135 closed defect (not a bug)

Bad CERTS cells in mixed chutney network

Reported by: teor Owned by:
Priority: Medium Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: regression, tor-dirauth, macOS, 035-roadmap-proposed, 035-can
Cc: teor Actual Points:
Parent ID: #27146 Points:
Reviewer: Sponsor:

Description

Yet another mixed network error - these race conditions really are exercising a whole lot of unusual code paths:

FAIL: mixed+hs-v2
Detail: chutney/tools/warnings.sh /Users/base/chutney/net/nodes.1537279328
Warning: Received a bad CERTS cell from 127.0.0.1:5002: Problem setting or checking peer id Number: 1
Warning: Received a bad CERTS cell from 127.0.0.1:5003: Problem setting or checking peer id Number: 1
Warning: Tried connecting to router at 127.0.0.1:5002, but RSA identity key was not as expected: wanted F0F7644942E7570548AA9BB1763F643123CE40C5 + no ed25519 key but got 72658EEB1AB9F6326635849C1D33052FC0C0F551 + 95IoksCTUXVIyqHU+lPMR3ppCzj+AdT5Bpg6BTSKDzI. Number: 1
Warning: Tried connecting to router at 127.0.0.1:5003, but RSA identity key was not as expected: wanted 185EF19538055B8B6F591224A66F0516C204BE98 + no ed25519 key but got 945CD7D474D11CA2A6DBEF63715477BA17657E68 + RT2D7+9+F4bADlz7427uBoUrV3iKtSz31l7/xT/xTls. Number: 1
Warning: http status 400 ("Nonauthoritative directory does not accept posted server descriptors") response from dirserver '127.0.0.1:7002'. Please correct. Number: 3
Warning: http status 400 ("Nonauthoritative directory does not accept posted server descriptors") response from dirserver '127.0.0.1:7003'. Please correct. Number: 3

Child Tickets

Change History (4)

comment:1 Changed 11 months ago by teor

I am still seeing this bug in 0.3.6.0-alpha-dev.

comment:2 Changed 11 months ago by teor

FAIL: hs-v2-min
Detail: chutney/tools/warnings.sh /Users/base/chutney/net/nodes.1540891267
Warning: HTTP status 404 ("Not found") was unexpected while uploading vote to server '127.0.0.1:7001'. Number: 1
Warning: Received a bad CERTS cell from 127.0.0.1:5001: Problem setting or checking peer id Number: 2
Warning: Tried connecting to router at 127.0.0.1:5001, but RSA + ed25519 identity keys were not as expected: wanted 9B1BA0C104914F4E54017C1782439590616DB164 + no ed25519 key but got 4AF4345F3A731ABDF0CC131174A2233B1DA9B071 + YsBEac4xBIBYuUOGmYiI/z0vciBNL16URUz4jZ7bbuo. Number: 2

comment:3 Changed 10 months ago by nickm

Keywords: 035-can added; 035-must removed

comment:4 Changed 6 months ago by teor

Resolution: not a bug
Status: newclosed

I haven't seen these bugs for a while, I suspect they were OS bugs, VM bugs, or clock errors. (Or we fixed them in another commit.)

Note: See TracTickets for help on using tickets.