Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#28171 closed defect (duplicate)

Problem: TOR v8.0.3 erases NoScript Per-Site Permissions when closed & requires re-import

Reported by: Questor Owned by:
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: noscript, tbb-regression, tbb-8.0-issues
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The latest TOR v8.0.3 Win32 Browser update 60.3.0esr release with a NoScript update as of 10/18/18 still does not fix TOR Devs breaking NoScript...

The problem that I have experienced for the past several months with Win10 v1803/v1809 is NoScript Per-Site Permissions auto-erased when TOR Browser closes and requires the manual re-import or rebuild of NoScript Per-Site Permissions.

If NoScript Per-Site Permissions are removed while running NoScript with TOR, most Internet websites access that use Javascript, Cookies, etc. are blocked until either the website is manually re-inserted into the NoScript Per-Site Permissions list or else NoScript is disabled as an add-on App.

Other TOR users have complained about recent TOR mods from TOR Devs that also broke NoScript. TOR Staff apparently closed these complaints as SOLVED without acknowledgement of the problem and no ETA for a fix...

Enclosed are TOR Troubleshooting text that describe the software environment on my Laptop.

Why did TOR break the use of NoScript Per-Site Permissions with TOR Win32 Browser that worked OK up to several months ago and is a fix currently scheduled for release?

Child Tickets

Attachments (2)

TOR Software 1 info.txt (9.7 KB) - added by Questor 12 months ago.
TOR Software 2 info.txt (7.3 KB) - added by Questor 12 months ago.

Download all attachments as: .zip

Change History (5)

Changed 12 months ago by Questor

Attachment: TOR Software 1 info.txt added

Changed 12 months ago by Questor

Attachment: TOR Software 2 info.txt added

comment:1 Changed 12 months ago by traumschule

Keywords: noscript tbb-regression tbb-8.0-issues added; NoScript Per-Site Permissions removed

Thanks for your report! This is #27175 which ought to be fixed.

Can you reproduce this with Tor Browser 8.5a3 as well?

comment:2 Changed 12 months ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #27175.

comment:3 Changed 12 months ago by gk

Component: - Select a componentApplications/Tor Browser
Version: Tor: unspecified
Note: See TracTickets for help on using tickets.