#28199 closed defect (duplicate)

Torlauncher fails when TB folder has been renamed

Reported by: traumschule Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by traumschule)

When i rename the tor-browser folder Torlauncher does not start.
To fix this the TorLauncher extension has to be disabled and re-enabled directly after. On the next start TorLauncher works as expected.


When TB quits it takes 30 seconds to give back the prompt because tor wants to exit gracefully after the lines

[notice] Owning controller connection has closed -- exiting now.
[notice] Catching signal TERM, exiting cleanly.

I just damaged my freshly updated 8.5a4 with ctrl+c on exit because i was impatient to wait. On the next start tor did not start anymore and gave no errors (i closed and opened TB several times without changes).

The about dialog says "Firefox Quantum" and no page is loaded (refused connection).

The log is missing any info on tor:

$ tbb-debug tor-browser_en-US8.5a4/                                                                                                                                           
Logging Tor Browser debug information to tor-browser.log                                                                                                                                              
Fontconfig warning: "/home/tbb/tor-browser_en-US8.5a4/Browser/TorBrowser/Data/fontconfig/fonts.conf", line 85: unknown element "blank"                                                                
alloc factor 0.900000 0.900000                                                                                                                                                                         
alloc factor 0.900000 0.900000                                                                                                                                              
Fontconfig warning: "/home/tbb/tor-browser_en-US8.5a4/Browser/TorBrowser/Data/fontconfig/fonts.conf", line 85: unknown element "blank"                                                                
alloc factor 0.900000 0.900000                                                                                                                                                                        
alloc factor 0.900000 0.900000                                                                                                                                                                        
Fontconfig warning: "/home/tbb/tor-browser_en-US8.5a4/Browser/TorBrowser/Data/fontconfig/fonts.conf", line 85: unknown element "blank"                                                                
^C                                                                                                                                                                                                     
tbb@t43:~$ tbb-debug tor-browser_en-US8.5a4/                                                                                                                                                          
Logging Tor Browser debug information to tor-browser.log                                                                                                               
Fontconfig warning: "/home/tbb/tor-browser_en-US8.5a4/Browser/TorBrowser/Data/fontconfig/fonts.conf", line 85: unknown element "blank"                                                                
alloc factor 0.900000 0.900000                                                                                                                                                                         
alloc factor 0.900000 0.900000                                                                                                                                                                        
Fontconfig warning: "/home/tbb/tor-browser_en-US8.5a4/Browser/TorBrowser/Data/fontconfig/fonts.conf", line 85: unknown element "blank"                                                                 
alloc factor 0.900000 0.900000                                                                                                                                                                        
alloc factor 0.900000 0.900000                                                                                                                                                                         
Fontconfig warning: "/home/tbb/tor-browser_en-US8.5a4/Browser/TorBrowser/Data/fontconfig/fonts.conf", line 85: unknown element "blank"
^C                                                                                                                                                                                                    

Log before it was damaged:

$ tbb-debug tor-browser_en-US8.5a1/                                                                                                                                                           
Logging Tor Browser debug information to tor-browser.log                                                                                                                                               
Fontconfig warning: "/home/tbb/tor-browser_en-US8.5a1/Browser/TorBrowser/Data/fontconfig/fonts.conf", line 85: unknown element "blank"                                                                 
alloc factor 0.900000 0.900000                                                                                                                                                                         
alloc factor 0.900000 0.900000                                                                                                                                                                         
Oct 25 11:49:34.507 [notice] Tor 0.3.5.3-alpha (git-444e9b37c53b0246) running on Linux with Libevent 2.1.8-stable, OpenSSL 1.0.2p, Zlib 1.2.11, Liblzma N/A, and Libzstd N/A.                          
Oct 25 11:49:34.528 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning                                                      
Oct 25 11:49:34.528 [notice] This version is not a stable Tor release. Expect more bugs than usual.                                                                                                    
Oct 25 11:49:34.546 [notice] Read configuration file "/media/user/tbb/tor-browser_en-US8.5a1/Browser/TorBrowser/Data/Tor/torrc-defaults".                                                              
Oct 25 11:49:34.585 [notice] Read configuration file "/media/user/tbb/tor-browser_en-US8.5a1/Browser/TorBrowser/Data/Tor/torrc".                                                                       
Oct 25 11:49:34.674 [notice] Opening Socks listener on 127.0.0.1:9150                                                                                                                                  
Oct 25 11:49:34.676 [notice] Opened Socks listener on 127.0.0.1:9150                                                                            
Oct 25 11:49:34.676 [notice] Opening Control listener on 127.0.0.1:9151                                                               
Oct 25 11:49:34.676 [notice] Opened Control listener on 127.0.0.1:9151                                                                
Fontconfig warning: "/home/tbb/tor-browser_en-US8.5a1/Browser/TorBrowser/Data/fontconfig/fonts.conf", line 85: unknown element "blank"
alloc factor 0.900000 0.900000                                                                                                                                                                        
alloc factor 0.900000 0.900000                                                                                                        
Fontconfig warning: "/home/tbb/tor-browser_en-US8.5a1/Browser/TorBrowser/Data/fontconfig/fonts.conf", line 85: unknown element "blank"                                                                
^C

TB should recognize that something is broken, tell the user that the bundle has been damaged and should be deleted and extracted again (even if this is obvious and users will figure it out, some may not and show up on #tor looking for support ..). Do we have any self-tests right now?

The last message on exit should say that it needs time to clean up at the end or similar.

Child Tickets

Change History (4)

comment:1 Changed 11 months ago by gk

Status: newneeds_information

I often quit my Tor Browser with Ctrl+c and have never managed to damage it so far. Can you reproduce that with a clean Tor Browser 8.5a4? If so, I'd be interested in seeing a diff between an 8.5a4 cleanly shutting down and an 8.5a4 that is damaged.

comment:2 Changed 11 months ago by traumschule

Description: modified (diff)
Summary: Interrupted exit damages TBTorlauncher fails when TB folder has been renamed

Adding update on top and keep outdated info as context.

comment:3 Changed 11 months ago by gk

I am confused by the description and summary change. How do you get from "Tor Browser does not start anymore after pressing Ctrl+c as it got corrupted" to "Tor Browser does not start anymore after the Tor Browser folder got renamed" in the same bug. Where is the connection between both?

comment:4 Changed 11 months ago by traumschule

Resolution: duplicate
Status: needs_informationclosed

Duplicate of #27604.

Note: See TracTickets for help on using tickets.