#28262 closed defect (not a bug)

HS v3 auth-private files loaded twice on startup

Reported by: jchevali Owned by:
Priority: Low Milestone:
Component: Core Tor Version: Tor: 0.3.5.3-alpha
Severity: Minor Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

tor-0.3.5.3-alpha is loading the contents of ClientOnionAuthDir twice on startup. This is occurring on Win32; I don't know about other platforms.

I learnt this indirectly because Tor complains twice about the bunch of private files whose extensions are invalid. Possibly this is not visible unless you have invalid files. And possibly the valid entries are not loaded twice, but once then overriden, but still.

Child Tickets

Change History (1)

comment:1 Changed 15 months ago by dgoulet

Resolution: not a bug
Status: newclosed

Yes this is normal because Tor has a "configuration validation" phase and then once it is consider valid, we end up in the "configuration loading" phase.

This is to support the tor --verify-config feature.

Note: See TracTickets for help on using tickets.