Opened 6 months ago

Closed 6 months ago

#28270 closed defect (not a bug)

2018 Donation Banner not shown after updating Tor Browser 8.0.3

Reported by: pili Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: sstevenson, isabela, arthuredelstein Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Some people are not seeing the 2018 Donation Banner after updating to the latest Tor Browser version

Child Tickets

Change History (6)

comment:1 Changed 6 months ago by gk

Priority: MediumHigh
Status: newneeds_information

isabela, can you give us details about what was happening? OS, which Tor Browser version you had before etc.?

More importantly can you reproduce that on your machine coming from an older version? Older ones can be found on https://archive.torproject.org/tor-package-archive/torbrowser/.

comment:2 Changed 6 months ago by gk

Cc: arthuredelstein added

comment:3 Changed 6 months ago by pili

isabela: also, are you still seeing the newsletter banner? or just not seeing the donation banner?

comment:4 Changed 6 months ago by arthuredelstein

The donation banner is programmed to appear 12 times only. So I wonder if it could be related to that? It would be helpful to look in about:config and check the value of the pref "extensions.torbutton.donation_banner_countdown". If this is set to "0", it means the user has already seen the banner the maximum number of times. (You can set it to a positive integer to make the banner appear again.) If the pref is not present, then we have a different problem.

comment:5 Changed 6 months ago by arthuredelstein

I have been trying out the donation banner but it seems to be working. I downloaded an Tor Browser 8.0.2 (en_US, linux) from https://archive.torproject.org/tor-package-archive/torbrowser/. I could see the old newsletter banner. Then I updated to 8.0.3. Two tabs were opened: the about:tbupdate tab which shows "Tor Browser has been updated," and then the about:tor tab, which I confirmed contains the donation banner.

Anyone who has seen this problem: as well as the operating system and Tor Browser version, can you mention what Tor Browser locale (language) you are using?

Last edited 6 months ago by arthuredelstein (previous) (diff)

comment:6 Changed 6 months ago by isabela

Resolution: not a bug
Status: needs_informationclosed

Hi there, I looked at my settings and I think I might have dismissed the banner while testing it and got in the bucket to never see it again. I also checked with Shari and she managed to see the banner. So I am closing this ticket for now as we can't seem to be able to reproduce the issue.

Note: See TracTickets for help on using tickets.