Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#28306 closed enhancement (not a bug)

Please add signing keys to db.torproject.org

Reported by: traumschule Owned by: tpa
Priority: Medium Milestone:
Component: Internal Services/Tor Sysadmin Team Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: #22637 Points:
Reviewer: Sponsor:

Description

Not entirely sure of this is in the scope of db.torproject.org:

For #22637 it would be useful to have all keys in the db which are listed on
https://www.torproject.org/docs/signing-keys.html.en

Then we could link to it instead of pgp.mit.edu which sometimes gives errors.

Child Tickets

Change History (2)

comment:1 Changed 9 months ago by weasel

Resolution: not a bug
Status: newclosed

I don't think that's in-scope. They keyring on db.tpo authenticates user requests to the user maintenance scripts and encrypts replies to the users.

If we wanted, we could extract keys from the keyring during the website build-process, but I suspect there are other keys on that page that are not part of the db.tpo keyring.

I'll close this as not-a-bug for now, but feel free to coordinate if you want to do something with the existing user-keys.

comment:2 Changed 9 months ago by traumschule

Parent ID: #22637
Note: See TracTickets for help on using tickets.