Opened 9 years ago

Closed 7 years ago

#2833 closed defect (not a bug)

Conflict with downthemall when torbutton is on

Reported by: malef Owned by: mikeperry
Priority: Very Low Milestone: TorBrowserBundle 2.2.x-stable
Component: TorBrowserButton Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points: 3
Reviewer: Sponsor:

Description

Hi all!

I have a problem that maybe not a bug but I cant find a solution to it.
recently I update my Firefox to 4 version and found out that tor has only alpha 1.3.2 version of TorButton for this version of Firefox. so I get it and it works ok for me except one thing - DownThemAll! plugin doesn't work when TorButton is turned on.
tried to turn off "Disable plugins on Tor Usage" but it didnt help me anyway.

is there any possibility to change options of TorButton to position when DownThemAll! plugin works? or I have to return to the 1.2.5 version of TorButton and 3.x version of Firefox?

Thanks a lot for help!

Child Tickets

Change History (5)

comment:1 Changed 9 years ago by mikeperry

Points: 3
Summary: cant run downthemall when torbutton is onConflict with downthemall when torbutton is on

comment:2 Changed 9 years ago by toruser99

I am having this same issue. still persists on torbrowser 2.2.25-1-alpha_en-US (windows) and the new 2.2.27-1-alpha-osx (on OSX), both have TorButton 1.3.3 alpha. Please investigate this bug, as downthemall is very useful. It may be preventing other add-ons from working, too.

comment:3 Changed 8 years ago by zulithe

Milestone: Torbutton: 1.3Torbutton: 1.4
Version: Torbutton: 1.3Torbutton: 1.4

Problem still exists in the new torbutton 1.4 stable.

disabling "isolate dynamic content" in TorButton Security Settings preferences is a temporary fix for the problem, but this is highly undesireable.

comment:4 Changed 8 years ago by mikeperry

Component: TorbuttonTorBrowserButton
Milestone: Torbutton: 1.4TorBrowserBundle 2.2.x-stable
Version: Torbutton: 1.4

comment:5 Changed 7 years ago by mikeperry

Priority: normaltrivial
Resolution: not a bug
Status: newclosed

We don't support other addons in TBB. If it breaks, you get to keep both pieces (including the one that ruined your anonymity).

Note: See TracTickets for help on using tickets.