Opened 5 months ago

Closed 5 months ago

#28331 closed defect (not a bug)

Tor gets my public ip address wrong. No wonder you cannot reach me.

Reported by: peterinprivate Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.3.4.8
Severity: Normal Keywords: public ip, split tunnelling
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm behind NAT on my ISP's router. I'm reachable on my ORPort until I set up my VPN. I use split tunnelling to exclude certain processes such as tor.exe. ORPort traffic is excluded from the VPN BUT tor thinks my IP address has changed from my real public address to the VPN tunnel's public address. What process determines my public address? I need to exclude this also from the VPN.

Child Tickets

Change History (2)

comment:1 Changed 5 months ago by nickm

You should be able to override Tor's choice for your address by using the Address option. You can use the sub-options (like nobind) for ORPort to pick a specific address to bind to without advertising it.

comment:2 Changed 5 months ago by dgoulet

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.