Opened 9 days ago

Closed 6 days ago

#28350 closed enhancement (duplicate)

Request for a Tor Circuit site which appears to be in the USA

Reported by: CrisBCT Owned by: < apparent IP address >
Priority: Medium Milestone:
Component: Internal Services Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Here in Europe I frequently find that a US site won't allow me to visit because I'm not in the USA. eg. www.cnbc.com/video/2018/08/16/jay-leno-chats-with-teslas-chief-designer-about-the-2020-tesla-roadster.html reports "Access Denied".

And I do know that "New Tor Circuit for this Site" will give another apparent location, but not necessarily a US location.

To resolve this problem TOR needs an enhancement to be able to request an apparent IP address for the Tor Circuit site which is in the USA...

Please add this to the requested enhancements list, as

Child Tickets

Attachments (1)

TOR Access Denied 2018:11:06.png (49.4 KB) - added by CrisBCT 9 days ago.
Screenshot showing Access Denied

Download all attachments as: .zip

Change History (5)

Changed 9 days ago by CrisBCT

Screenshot showing Access Denied

comment:1 Changed 9 days ago by gk

Resolution: not a bug
Status: assignedclosed

That's already possible, see the ExitNodes section in the man page.

comment:2 Changed 7 days ago by CrisBCT

Resolution: not a bug
Status: closedreopened

If "the man page" means the manual then there's no search option that I can see. Is there a search option for the manual, there must be one - where is it hiding?

Nor is ExitNodes found in the page search in case man means in the managing identities section. Where can I find ExitNodes? I'd like to add a screenshot showing this Not-Found but can't see how to add an image to this comment...

Please give the man page url which describes how to specify a TOR Circuit site in the USA.

Last edited 7 days ago by CrisBCT (previous) (diff)

comment:3 in reply to:  2 Changed 6 days ago by catalyst

Replying to CrisBCT:

If "the man page" means the manual then there's no search option that I can see. Is there a search option for the manual, there must be one - where is it hiding?

Nor is ExitNodes found in the page search in case man means in the managing identities section. Where can I find ExitNodes? I'd like to add a screenshot showing this Not-Found but can't see how to add an image to this comment...

Please give the man page url which describes how to specify a TOR Circuit site in the USA.

What URL were you looking at? Was it the Tor Browser manual at https://tb-manual.torproject.org/en-US/ ?

What gk was referring to was likely the Unix man page for the tor daemon that Tor Browser runs. It's possible to edit its torrc file to specify an ExitNodes. See https://www.torproject.org/docs/tor-manual.html.en for a web rendering of a recent tor man page.

As far as I know, there is no option (yet) to specify ExitNodes through the Tor Browser UI. There's already a feature request ticket open at #14181, so I'm closing this as a duplicate.

comment:4 Changed 6 days ago by catalyst

Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.