Opened 6 months ago

Closed 3 months ago

Last modified 6 weeks ago

#28405 closed defect (duplicate)

Unable to parse networkstatus consensus (related to CR in time field)

Reported by: nth Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor: Sponsor8

Description

tor reloads cached-microdesc-consensus at start and put old to unparseable-descs folder, but then tor works fine.

Nov 12 06:27:43.707 [notice] Tor 0.4.0.0-alpha-dev (git-d1e9285b1de1f6ec) running on Very recent version of Windows [major=6,minor=3]
...
Nov 12 06:27:44.000 [notice] Bootstrapped 0%: Starting
Nov 12 06:27:44.000 [warn] ISO time "2018-11-12 03:00:00\r" was unparseable
Nov 12 06:27:44.000 [warn] Unable to parse networkstatus consensus
Nov 12 06:27:44.000 [warn] Couldn't load consensus microdesc networkstatus from cache
Nov 12 06:27:44.000 [notice] Starting with guard context "default"
Nov 12 06:27:45.000 [notice] Bootstrapped 5%: Connecting to directory server
Nov 12 06:28:27.000 [notice] Bootstrapped 10%: Finishing handshake with directory server
Nov 12 06:28:27.000 [notice] Bootstrapped 15%: Establishing an encrypted directory connection
Nov 12 06:28:27.000 [notice] Bootstrapped 20%: Asking for networkstatus consensus
Nov 12 06:28:27.000 [notice] Bootstrapped 25%: Loading networkstatus consensus
Nov 12 06:28:33.000 [notice] Bootstrapped 80%: Connecting to the Tor network
Nov 12 06:28:33.000 [notice] Bootstrapped 85%: Finishing handshake with first hop
Nov 12 06:28:34.000 [notice] Bootstrapped 90%: Establishing a Tor circuit
Nov 12 06:28:35.000 [notice] Bootstrapped 100%: Done


Child Tickets

Change History (6)

comment:1 Changed 6 months ago by nickm

Summary: Unable to parse networkstatus consensusUnable to parse networkstatus consensus (related to CR in time field)

comment:2 Changed 6 months ago by dgoulet

Milestone: Tor: unspecified

comment:3 Changed 5 months ago by teor

Parent ID: #28614

comment:4 Changed 3 months ago by dgoulet

Parent ID: #28614

comment:5 Changed 3 months ago by teor

Resolution: duplicate
Status: newclosed

This was a duplicate of #28614, which is now fixed in master,

Thanks for the bug report!

comment:6 Changed 6 weeks ago by teor

Sponsor: Sponsor8

Related to #27244.

Note: See TracTickets for help on using tickets.