Opened 6 months ago

Closed 6 months ago

#28456 closed task (fixed)

translation.git repo needs a git prune

Reported by: emmapeel Owned by: tor-gitadm
Priority: Medium Milestone:
Component: Internal Services/Service - git Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

It seems that the local repository at /srv/git.torproject.org/ - git-rw.torproject.org needs a git prune, because since a while, each time I push I get the message:

remote: via /srv/git.torproject.org/git-helpers/post-receive-diff
remote: == 00-sync-to-mirror ==
remote: == commit-mail ==
remote: == github-push ==
remote: == irc-message ==
remote: == per-repo-hook ==
remote: == xx-jenkins-trigger ==
remote: [hook[15951]] Triggering jenkins build for (https://git.torproject.org/translation.git, torbutton-torbuttonproperties_completed, aebe13ad3be592d08e56df13d9d46a866e5839de).
remote: No git jobs using repository: https://git.torproject.org/translation.git and branches: torbutton-torbuttonproperties_completed
remote: No Git consumers using SCM API plugin for: https://git.torproject.org/translation.git
remote: [hook[15951]] Jenkins triggers done.
remote: error: The last gc run reported the following. Please correct the root cause
remote: and remove gc.log.
remote: Automatic cleanup will not be performed until the file is removed.
remote:
remote: warning: disabling bitmap writing, as some objects are not being packed
remote:

Please have a look and git prune && git gc the repo.

Child Tickets

Change History (3)

comment:1 Changed 6 months ago by irl

Resolution: fixed
Status: newclosed

comment:2 Changed 6 months ago by emmapeel

Resolution: fixed
Status: closedreopened

This is still happening. Maybe there is another repo? In jenkins?

The message is, after git push:

Enumerating objects: 8, done.
Counting objects: 100% (8/8), done.
Delta compression using up to 2 threads
Compressing objects: 100% (4/4), done.
Writing objects: 100% (6/6), 715 bytes | 715.00 KiB/s, done.
Total 6 (delta 2), reused 0 (delta 0)
remote: via /srv/git.torproject.org/git-helpers/post-receive-diff
remote: == 00-sync-to-mirror ==
remote: == commit-mail ==
remote: == github-push ==
remote: == irc-message ==
remote: == per-repo-hook ==
remote: == xx-jenkins-trigger ==
remote: [hook[2010]] Triggering jenkins build for (https://git.torproject.org/translation.git, tbmanual-contentspot, abccb75bdd1a01f7f17e3856a28d4eed8841847a).
remote: No git jobs using repository: https://git.torproject.org/translation.git and branches: tbmanual-contentspot
remote: No Git consumers using SCM API plugin for: https://git.torproject.org/translation.git
remote: [hook[2010]] Jenkins triggers done.
remote: error: The last gc run reported the following. Please correct the root cause
remote: and remove gc.log.
remote: Automatic cleanup will not be performed until the file is removed.
remote:
remote: warning: disabling bitmap writing, as some objects are not being packed
remote: warning: There are too many unreachable loose objects; run 'git prune' to remove them.
remote:
To ssh://git-rw.torproject.org/translation.git

58fcea331..abccb75bd tbmanual-contentspot -> tbmanual-contentspot

comment:3 Changed 6 months ago by irl

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.