#28552 closed defect (not a bug)

Should stem integ tests fail on controller errors?

Reported by: teor Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Stem Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I see the following output in stem's integ tests:
https://travis-ci.org/teor2345/tor/jobs/457780454#L3524

01/01/1970 03:25:45 [WARNING] Event listener raised an uncaught exception (boom): CIRC 4 LAUNCHED
01/01/1970 03:25:45 [ERROR] Tor sent a malformed event (A BW event's bytes sent and received should be a positive numeric value, received: BW &15* 25): BW &15* 25

What's the error?
Is tor really outputting BW &15* 25, because the relevant code is 650 BW %lu %lu\r\n?
Why are the times in 1970?

Child Tickets

Change History (5)

comment:1 Changed 11 months ago by teor

Oh, and should stem fail on this kind of error?

comment:2 Changed 11 months ago by atagar

Hi teor, this is probably from...

https://gitweb.torproject.org/stem.git/tree/test/unit/control/controller.py#n685

You're seeing these because you're running run_tests.py with "--log notice". From stem's standpoint all looks well to me. The '--log' argument is intended for troubleshooting. Logged messages don't necessarily indicate problems.

comment:3 in reply to:  description Changed 11 months ago by teor

I am still confused by these issues, which look like bugs:

Replying to teor:

Is tor really outputting BW &15* 25, because the relevant code is 650 BW %lu %lu\r\n?
Why are the times in 1970?

comment:4 Changed 11 months ago by atagar

The test I pointed to is exercising Stems code path for 'tor sends us invalid content'. Unit tests don't even have a tor instance running, so 100% of things it cites concerns just stem - not tor.

Actually, for tor's purposes it might be worthwhile to swap your '--all' argument to '--integ'.

comment:5 Changed 11 months ago by teor

Resolution: not a bug
Status: newclosed

Thanks, I opened #28568 to follow this up.

Note: See TracTickets for help on using tickets.