Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#28574 closed defect (fixed)

Appveyor: OpenSSL unit test fails with header and library version mismatch

Reported by: teor Owned by:
Priority: Very High Milestone: Tor: 0.3.4.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-test, tor-ci, windows, appveyor, regression, openssl-1.1, 035-backport, 034-backport, 033-backport, 029-backport
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm guessing that 1.1.1a and 1.1.1 are compatible, though?

crypto/openssl_version: [forking] 
  FAIL ../src/test/test_crypto.c:238: OpenSSL library version 1.1.1 did not begin with header version 1.1.1a.
  [openssl_version FAILED]

https://ci.appveyor.com/project/torproject/tor/build/1.0.1625/job/gibgc64fp4hxsf2h?fullLog=true#L3064

Child Tickets

Change History (9)

comment:1 Changed 8 months ago by teor

Summary: Appveyor: OpenSSL unit test failsAppveyor: OpenSSL unit test fails with header and library version mismatch

comment:2 Changed 8 months ago by ahf

Status: newneeds_review

comment:4 Changed 8 months ago by nickm

Status: needs_reviewneeds_revision

Looks okay to me. Request:

  • Could you please backport this to whichever version first supported appveyor? I think it was 0.3.4.

Question:

  • Did you look over the history of this file? I know there have been other changes there recently, especially wrt the version of openssl, and I wonder if we've undoing anything important here.

comment:5 Changed 8 months ago by ahf

  1. Will do.
  2. Looks like the last change was in 4c3d61b5f2450ff8bf81f02bbaa2a42baa7af372 for bug #28399.

Maybe Tim have something to say here too? Looks like they have been fixing issues like this is a couple of times before.

comment:6 Changed 8 months ago by ahf

Let's see what the bots say: branch against maint-0.3.4 here: https://github.com/torproject/tor/pull/549

comment:7 Changed 8 months ago by ahf

Status: needs_revisionneeds_review

Looks like the bots are green. Requesting another review here.

comment:8 Changed 8 months ago by nickm

Milestone: Tor: 0.4.0.x-finalTor: 0.3.4.x-final
Resolution: fixed
Status: needs_reviewclosed

Okay, lgtm. Merged to 0.3.4 and forward.

comment:9 Changed 8 months ago by teor

Seems fine to me: if the installed version works, let's use it.

Note: See TracTickets for help on using tickets.