Opened 9 months ago

Closed 9 months ago

#28599 closed defect (not a bug)

bandwidth-file-spec.txt: bandwidth-avg is not calculated from any bandwidth burst option

Reported by: juga Owned by:
Priority: Medium Milestone: Tor: 0.4.0.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: #25925 Points:
Reviewer: Sponsor:

Description

    bandwidth-avg is the minimum of MaxAdvertisedBandwidth,
    BandwidthRate, RelayBandwidthRate, BandwidthBurst, and
    RelayBandwidthBurst.

(https://gitweb.torproject.org/torspec.git/tree/bandwidth-file-spec.txt#n315)

This should be:

    bandwidth-avg is the minimum of MaxAdvertisedBandwidth, BandwidthRate, RelayBandwidthRate,
    bandwidth-burst is the minimum of BandwidthBurst, and RelayBandwidthBurst.

Child Tickets

Change History (2)

comment:1 Changed 9 months ago by juga

Milestone: Tor: 0.4.0.x-final
Parent ID: #25925

comment:2 Changed 9 months ago by teor

Resolution: not a bug
Status: newclosed

If RelayBandwidthRate or RelayBandwidthBurst are missing from tor's config, the other option is used. RelayBandwidthRate must be less than or equal to RelayBandwidthBurst, or Tor won't start:
https://github.com/torproject/tor/blob/2b2b97484ad07c91ac410735a96fe8710e60cf23/src/app/config/config.c#L3936

So I think the spec is accurate, but the calculations are done in a few different places.

Note: See TracTickets for help on using tickets.