Opened 13 months ago

Closed 13 months ago

Last modified 9 months ago

#28613 closed defect (duplicate)

Log is filled with OpenSSL errors

Reported by: Vort Owned by:
Priority: Medium Milestone: Tor: 0.4.0.x-final
Component: Core Tor/Tor Version: Tor: 0.3.5.5-alpha
Severity: Normal Keywords: ssl
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I run tor.exe -f torrc, log file becomes filled with such lines:

Nov 25 19:51:46.000 [warn] Unhandled OpenSSL errors found at connection_or.c:1685: 
Nov 25 19:51:46.000 [warn] TLS error: internal error (in SSL routines:tls13_hkdf_expand:---)
Nov 25 19:51:47.000 [warn] Unhandled OpenSSL errors found at buffers_tls.c:69: 
Nov 25 19:51:47.000 [warn] TLS error: internal error (in SSL routines:tls13_hkdf_expand:---)

Version tested: 3741f9e5 on Windows 7 SP1 x64, configured with --disable-gcc-hardening and compiled by MSYS2 with following libraries: Libevent 2.1.8-stable, OpenSSL 1.1.1a, Zlib 1.2.11, Liblzma 5.2.4, and Libzstd 1.3.7.

Child Tickets

Change History (5)

comment:1 Changed 13 months ago by Vort

Component: - Select a componentCore Tor/Tor

comment:2 Changed 13 months ago by nickm

Keywords: 035-backport added
Milestone: Tor: 0.4.0.x-final

comment:3 Changed 13 months ago by arma

See #28616 for a very related issue but on linux

Is the issue openssl 1.1.1a?

comment:4 Changed 13 months ago by nickm

Resolution: duplicate
Status: newclosed

Closing as a duplicate of #28616, which has a diagnosis for the issue. It appears to be a regression in openssl 1.1.1a.

comment:5 Changed 9 months ago by teor

Keywords: 035-backport removed

Remove tags from duplicate.

Note: See TracTickets for help on using tickets.