Opened 2 years ago

Closed 2 years ago

#28641 closed defect (duplicate)

conn_close_if_marked: Non-fatal assertion !(connection_is_reading(conn)) failed

Reported by: TheBoegl Owned by:
Priority: High Milestone:
Component: Core Tor/Tor Version: Tor: 0.3.4.9
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I got the following log entry on Ubuntu 18.04.1 LTS:

Nov 27 21:36:40 server Tor-samaadams[14901]: tor_bug_occurred_(): Bug: ../src/or/main.c:1047: conn_close_if_marked: Non-fatal assertion !(connection_is_reading(conn)) failed. (on Tor 0.3.4.9 )
Nov 27 21:36:40 server Tor-samaadams[14901]: Bug: Non-fatal assertion !(connection_is_reading(conn)) failed in conn_close_if_marked at ../src/or/main.c:1047. Stack trace: (on Tor 0.3.4.9 )
Nov 27 21:36:40 server Tor-samaadams[14901]: Bug:     /usr/bin/tor(log_backtrace+0x43) [0x55feb610d2a3] (on Tor 0.3.4.9 )
Nov 27 21:36:40 server Tor-samaadams[14901]: Bug:     /usr/bin/tor(tor_bug_occurred_+0xb9) [0x55feb61282d9] (on Tor 0.3.4.9 )
Nov 27 21:36:40 server Tor-samaadams[14901]: Bug:     /usr/bin/tor(+0x54631) [0x55feb5fd9631] (on Tor 0.3.4.9 )
Nov 27 21:36:40 server Tor-samaadams[14901]: Bug:     /usr/bin/tor(+0x54a9e) [0x55feb5fd9a9e] (on Tor 0.3.4.9 )
Nov 27 21:36:40 server Tor-samaadams[14901]: Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.1.so.6(+0x1ea11) [0x7f1727e99a11] (on Tor 0.3.4.9 )
Nov 27 21:36:40 server Tor-samaadams[14901]: Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.1.so.6(event_base_loop+0x53f) [0x7f1727e9a33f] (on Tor 0.3.4.9 )
Nov 27 21:36:40 server Tor-samaadams[14901]: Bug:     /usr/bin/tor(do_main_loop+0x212) [0x55feb5fdbca2] (on Tor 0.3.4.9 )
Nov 27 21:36:40 server Tor-samaadams[14901]: Bug:     /usr/bin/tor(tor_run_main+0x11a5) [0x55feb5fde4a5] (on Tor 0.3.4.9 )
Nov 27 21:36:40 server Tor-samaadams[14901]: Bug:     /usr/bin/tor(tor_main+0x3a) [0x55feb5fd625a] (on Tor 0.3.4.9 )
Nov 27 21:36:40 server Tor-samaadams[14901]: Bug:     /usr/bin/tor(main+0x19) [0x55feb5fd5fe9] (on Tor 0.3.4.9 )
Nov 27 21:36:40 server Tor-samaadams[14901]: Bug:     /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xe7) [0x7f172663ab97] (on Tor 0.3.4.9 )
Nov 27 21:36:40 server Tor-samaadams[14901]: Bug:     /usr/bin/tor(_start+0x2a) [0x55feb5fd603a] (on Tor 0.3.4.9 )

Child Tickets

Change History (2)

comment:1 Changed 2 years ago by nickm

Hi! Thanks for reporting this! It looks like a duplicate of #27750.

comment:2 Changed 2 years ago by dgoulet

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.