#28666 closed defect (fixed)

Spellcheck wont work on TorBrowser Version 8.0.3 - Linux (64-Bit) for spanish laguange

Reported by: CaptainCookie Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: TorBrowserTeam201812
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Spellcheck wont work on TorBrowser Version 8.0.3 - Linux (64-Bit)

Allways have spell check enabled on general settings

For spanish laguange version of TorBrowser spellcheck is missed in the menu of mouse righ click over text boxes.

For english version of torbrowser, I install spanish dictionary from https://addons.mozilla.org/en-US/firefox/language-tools/ but TorBrowser wont display it on the menu when make right click in a text box to choose a language.

Thanks!!

Child Tickets

Attachments (1)

28666_en-US.png (27.2 KB) - added by gk 20 months ago.

Download all attachments as: .zip

Change History (10)

comment:1 in reply to:  description Changed 21 months ago by gk

Status: newneeds_information

Replying to CaptainCookie:

Spellcheck wont work on TorBrowser Version 8.0.3 - Linux (64-Bit)

Allways have spell check enabled on general settings

Yes, that should be on by default in Tor Browser.

For spanish laguange version of TorBrowser spellcheck is missed in the menu of mouse righ click over text boxes.

Indeed, I can reproduce that, thanks!

For english version of torbrowser, I install spanish dictionary from https://addons.mozilla.org/en-US/firefox/language-tools/ but TorBrowser wont display it on the menu when make right click in a text box to choose a language.

Where do you click here exactly? Is that in some browser menu? I think I am not sure how to reproduce this problem.

Thanks!!

Thanks!

comment:2 Changed 21 months ago by CaptainCookie

Where do you click here exactly? Is that in some browser menu? I think I am not sure how to reproduce this problem.

First install the spanish dictionary. Then go to a web site with a text box to type a message (I note this on twitter). Inside that text box make a right clic then a menu appears. In that menu in the "languages" submenu the spanish dictionary option should appears, but it don't and only shows the english option.
https://ibb.co/Z1xvCFd

Next pic is to show that spanish dictionary is installed
https://ibb.co/54JZVVL

Sorry for my english :)

Thanks!!

Last edited 21 months ago by CaptainCookie (previous) (diff)

comment:3 Changed 20 months ago by CaptainCookie

There is any news about this issue?

Changed 20 months ago by gk

Attachment: 28666_en-US.png added

comment:4 in reply to:  2 ; Changed 20 months ago by gk

Replying to CaptainCookie:

Where do you click here exactly? Is that in some browser menu? I think I am not sure how to reproduce this problem.

First install the spanish dictionary. Then go to a web site with a text box to type a message (I note this on twitter). Inside that text box make a right clic then a menu appears. In that menu in the "languages" submenu the spanish dictionary option should appears, but it don't and only shows the english option.
https://ibb.co/Z1xvCFd

This works for me, somewhat surprisingly:


Next pic is to show that spanish dictionary is installed
https://ibb.co/54JZVVL

That's weird. How did you get your dictionary into the Extensions section? You should have it in an own Dictionaries section (as I have when testing that).

Last edited 20 months ago by gk (previous) (diff)

comment:5 Changed 20 months ago by spanish

Dictionaries are now WebExtensions, but Mozilla forgot about compatibility settings (as in lpks). See https://addons.mozilla.org/en-US/firefox/addon/spanish-spain-dictionary/versions/
Also would you be so kind to bundle appropriate dictionary with every locale?

comment:6 in reply to:  5 ; Changed 20 months ago by gk

Replying to spanish:

Dictionaries are now WebExtensions, but Mozilla forgot about compatibility settings (as in lpks). See https://addons.mozilla.org/en-US/firefox/addon/spanish-spain-dictionary/versions/

Are you saying installing from that link causes the problem? I tried https://addons.mozilla.org/en-US/firefox/language-tools/ as the reporter indicated.

Also would you be so kind to bundle appropriate dictionary with every locale?

I am not sure. What is Mozilla doing?

comment:7 in reply to:  6 Changed 20 months ago by spanish

Replying to gk:

Replying to spanish:

Dictionaries are now WebExtensions, but Mozilla forgot about compatibility settings (as in lpks). See https://addons.mozilla.org/en-US/firefox/addon/spanish-spain-dictionary/versions/

Are you saying installing from that link causes the problem? I tried https://addons.mozilla.org/en-US/firefox/language-tools/ as the reporter indicated.

Version 2.3.1webext Released Nov. 28, 2018 is the first webext version, not tested with esr.

Also would you be so kind to bundle appropriate dictionary with every locale?

I am not sure. What is Mozilla doing?

lpk+dic is better than lpk. Why do you care?

comment:8 in reply to:  4 Changed 20 months ago by CaptainCookie

Replying to gk:

Replying to CaptainCookie:

Where do you click here exactly? Is that in some browser menu? I think I am not sure how to reproduce this problem.

First install the spanish dictionary. Then go to a web site with a text box to type a message (I note this on twitter). Inside that text box make a right clic then a menu appears. In that menu in the "languages" submenu the spanish dictionary option should appears, but it don't and only shows the english option.
https://ibb.co/Z1xvCFd

This works for me, somewhat surprisingly:

Next pic is to show that spanish dictionary is installed
https://ibb.co/54JZVVL

That's weird. How did you get your dictionary into the Extensions section? You should have it in an own Dictionaries section (as I have when testing that).

For the last update (tor-browser-linux64-8.0.4 _en-US) dictionaries are working again. Don't forget that I started this ticket with 8.0.3 version.

For Spanish version update you need to install dictionary manually to work since it does not come preinstalled.

comment:9 Changed 20 months ago by gk

Keywords: TorBrowserTeam201812 added; spell check removed
Resolution: fixed
Status: needs_informationclosed

Okay, so this actually seems to be a bug that got fixed in Firefox 60.4.0esr. Maybe by https://bugzilla.mozilla.org/show_bug.cgi?id=1410214 and related bugs, closing.

Note: See TracTickets for help on using tickets.