Opened 4 months ago

Closed 4 months ago

#28671 closed defect (not a bug)

Travis seems to fail to start tor

Reported by: juga Owned by:
Priority: Medium Milestone: sbws: 1.0.x-final
Component: Core Tor/sbws Version:
Severity: Normal Keywords:
Cc: juga, teor Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

sbws integration tests are failing because tor does not start anymore in Travis.
When sbws try to launch it itself, the error is:

    def timeout_handler(signum, frame):
>     raise OSError('reached a %i second timeout without success' % timeout)
E     OSError: reached a 90 second timeout without success

https://travis-ci.org/juga0/sbws/jobs/461879325#L1480
When wait.py try to connect to the Tor test network, the error is:

  File "/home/travis/build/torproject/sbws/.tox/integration/lib/python3.6/site-packages/stem/socket.py", line 525, in _make_socket
    control_socket.connect((self.address, self.port))
ConnectionRefusedError: [Errno 111] Connection refused

https://travis-ci.org/torproject/sbws/jobs/461798812#L1190

I've tried to solve it in branch https://github.com/juga0/sbws/tree/travis_tor unsuccessfully. Not sure why this started to fail today.

Child Tickets

Change History (1)

comment:1 Changed 4 months ago by juga

Resolution: not a bug
Status: newclosed

Now tests pass, seems Travis was just being slow

Note: See TracTickets for help on using tickets.