Opened 4 months ago

Closed 3 months ago

#28720 closed defect (fixed)

NoScript is blocking some videos outright starting with 10.1.9.2rc2 on security level "safer"

Reported by: gk Owned by: ma1
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: noscript, TorBrowserTeam201812R
Cc: ma1 Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by gk)

STR:

1) Take a clean Tor Browser
2) Set the security slider level to "safer" (click on the onion in the toolbar -> Security Settings... -> drag the slider to the medium level)
3) Load https://developer.mozilla.org/samples/video/chroma-key/index.xhtml
4) You get the message "No video with supported format and MIME type found." without the option to override this in order to watch the video.

Expected results:

The NoScript placeholder allowing to watch the video after clicking on it and confirming.

The last good version is NoScript 10.1.9.2rc1 and the first bad one 10.1.9.2rc2

This got reported on our blog: https://blog.torproject.org/comment/278685#comment-278685

Child Tickets

Change History (13)

comment:1 Changed 4 months ago by gk

Summary: NoScript is blocking some videos outright starting with 10.1.9.2rc2 on security leverl "safer"NoScript is blocking some videos outright starting with 10.1.9.2rc2 on security level "safer"

comment:2 Changed 4 months ago by gk

In case this is relevant: this happens on a 64bit Debian box.

comment:3 Changed 4 months ago by gk

Description: modified (diff)

comment:4 Changed 4 months ago by ma1

Owner: changed from tbb-team to ma1
Status: newassigned

Actually as far as I can see last "good" version is 10.1.9.1 (10.1.9.2rc1 already exhibits the bug for me). Investigating, thanks.

comment:5 Changed 4 months ago by ma1

Status: assignedneeds_review

Fixed in 10.2.1rc1, thanks.

comment:6 in reply to:  5 Changed 4 months ago by gk

Status: needs_reviewneeds_revision

Replying to ma1:

Fixed in 10.2.1rc1, thanks.

That gives the placeholder back, thanks. But once I allow the video to get it played I run into the same error as outlined in 4) in comment:description (instead of seeing a running video). So, this needs revision.

comment:7 Changed 4 months ago by ma1

Status: needs_revisionneeds_review

The replaced video element not automatically reloading the media should also be fixed in 10.2.1rc2, thanks.

comment:8 Changed 4 months ago by gk

Keywords: TorBrowserTeam201812R added

comment:9 Changed 4 months ago by omg

NoScript's icon is not updated.

comment:12 in reply to:  7 Changed 3 months ago by gk

Replying to ma1:

The replaced video element not automatically reloading the media should also be fixed in 10.2.1rc2, thanks.

Looks good to me, thanks. I'll close the ticket once a new NoScript version containing this fix is out and I bumped the version we ship.

comment:13 Changed 3 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

Fixed with the update to NoScript 10.2.1 on master (commit b32e182633bba7733b635bc5dd0fcbd55436f4d7) and maint-8.0 (commit b35cea6792f294d0a625fde5595f1c96a8a2a72a).

Note: See TracTickets for help on using tickets.